POJ2263 Heavy Cargo SPFA

一道最小路径思想的题目,可以用floyd来做,这里我选择了spfa,来练习了一下算法。

 

Heavy Cargo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2260 Accepted: 1251

Description

Big Johnsson Trucks Inc. is a company specialized in manufacturing big trucks. Their latest model, the Godzilla V12, is so big that the amount of cargo you can transport with it is never limited by the truck itself. It is only limited by the weight restrictions that apply for the roads along the path you want to drive.

Given start and destination city, your job is to determine the maximum load of the Godzilla V12 so that there still exists a path between the two specified cities.

Input

The input will contain one or more test cases. The first line of each test case will contain two integers: the number of cities n (2<=n<=200) and the number of road segments r (1<=r<=19900) making up the street network.
Then r lines will follow, each one describing one road segment by naming the two cities connected by the segment and giving the weight limit for trucks that use this segment. Names are not longer than 30 characters and do not contain white-space characters. Weight limits are integers in the range 0 - 10000. Roads can always be travelled in both directions.
The last line of the test case contains two city names: start and destination.
Input will be terminated by two values of 0 for n and r.

Output

For each test case, print three lines:
  • a line saying "Scenario #x" where x is the number of the test case
  • a line saying "y tons" where y is the maximum possible load
  • a blank line

Sample Input

4 3
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Muenchen
5 5
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Hamburg 220
Hamburg Muenchen 170
Muenchen Karlsruhe
0 0

Sample Output

Scenario #1
80 tons
 
Scenario #2
170 tons
#include<iostream>
#include<queue>
#include<vector>
#include<cstring>
#include<string>
#include<map>
#include<algorithm>

using namespace std;

#define INF 0xFFFFFF
#define MAXN 220

struct node
{
	int to;
	int w;
};

map<string,int> hash;
vector<node>  g[MAXN];
int dis[MAXN];
int n,m;
bool in[MAXN];
int cases=1;

void init()
{
	int num=1;
	string a,b;
	node temp;
	int w;
	hash.clear();
	for(int i=0;i<=n;i++)
		g[i].clear();
	for(int i=1;i<=m;i++)
	{
		cin>>a>>b>>w;
		if(hash.count(a)==0)
			hash[a]=num++;
		if(hash.count(b)==0)
			hash[b]=num++;
		temp.to=hash[a];
		temp.w=w;
		g[hash[b]].push_back(temp);
		temp.to=hash[b];
		g[hash[a]].push_back(temp);
	}
}

void spfa(int s)
{
	queue<int> q;
	for(int i=1;i<=n;i++)
	{
		dis[i]=0;
		in[i]=false;
	}
	dis[s]=INF;
	in[s]=true;
	q.push(s);
	while(!q.empty())
	{
		int tag;
		tag=q.front();
		q.pop();
		for(int i=0;i<g[tag].size();i++)
		{
			int j=g[tag][i].to;
			int temp=max(dis[j],min(dis[tag],g[tag][i].w));
			if(temp>dis[j])
			{
				dis[j]=temp;
				if(!in[j])
				{
					in[j]=true;
					q.push(j);
				}
			}
		}
	}
}

void solve()
{
	string s1,s2;
	cin>>s1>>s2;
	int x,y;
	x=hash[s1];
	y=hash[s2];
	spfa(x);
	cout<<"Scenario #"<<cases++<<endl;
	cout<<dis[y]<<" tons"<<endl<<endl;
	
}

int main()
{
	
	while(cin>>n>>m && n+m!=0)
	{
		init();
		
		solve();
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值