Heavy Cargo(弗洛伊德——最小生成树)

Description

Big Johnsson Trucks Inc. is a company specialized in manufacturing big trucks. Their latest model, the Godzilla V12, is so big that the amount of cargo you can transport with it is never limited by the truck itself. It is only limited by the weight restrictions that apply for the roads along the path you want to drive. 

Given start and destination city, your job is to determine the maximum load of the Godzilla V12 so that there still exists a path between the two specified cities. 

Input

The input will contain one or more test cases. The first line of each test case will contain two integers: the number of cities n (2<=n<=200) and the number of road segments r (1<=r<=19900) making up the street network. 
Then r lines will follow, each one describing one road segment by naming the two cities connected by the segment and giving the weight limit for trucks that use this segment. Names are not longer than 30 characters and do not contain white-space characters. Weight limits are integers in the range 0 - 10000. Roads can always be travelled in both directions. 
The last line of the test case contains two city names: start and destination. 
Input will be terminated by two values of 0 for n and r.

Output

For each test case, print three lines: 
  • a line saying "Scenario #x" where x is the number of the test case 
  • a line saying "y tons" where y is the maximum possible load 
  • a blank line

Sample Input

4 3
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Muenchen
5 5
Karlsruhe Stuttgart 100
Stuttgart Ulm 80
Ulm Muenchen 120
Karlsruhe Hamburg 220
Hamburg Muenchen 170
Muenchen Karlsruhe
0 0

Sample Output

Scenario #1
80 tons
 
Scenario #2
170 tons

题目大意:

Johnsson是一个货车司机,他从起点到达终点要经过几个城市,每两个城市之间的道路上,货车的载重量有所限制,给出一组数据,求出起点到终点的最大载重量。


解题思路:

弗洛伊德算法查找最小生成树,与此同时记录最小权值。


代码如下:

#include <iostream>
#include <stdio.h>
#include <string>
#include <map>
#include <string.h>
using namespace std;
#define N 210
#define INF 0x3ffffff
map<string, int > g;
int n,r;
int mat[N][N];

void floyd()
{
	for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if( mat[i][j] < min (mat[i][k],mat[k][j]) )
					mat[i][j] = min(mat[i][k],mat[k][j]);
            }
        }
    }
}
int main()
{
	int num=1,cnt,w;
	char str1[35],str2[35];
	while(scanf("%d%d",&n,&r))
	{
	    if(n==0&&r==0)
            break;
		memset(mat,0,sizeof(mat));
		cnt=1;
		for(int i=0;i <r;i++)
		{
		    scanf("%s %s %d",str1,str2,&w);
			if(g[str1]==0)
			{
				g[str1]=cnt++;
			}
			if(g[str2]==0)
			{
				g[str2]=cnt++;
			}
			mat[g[str1]][g[str2]]=mat[ g[str2] ][ g[str1] ]=w;
		}
		floyd();
		scanf("%s %s",str1,str2);
		printf("Scenario #%d\n",num++);
		printf("%d tons\n",mat[ g[str1] ][ g[str2] ]);
		printf("\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值