HDU4006 The kth great number 线段树

一开始犹豫了,以为有负数。但试着用了线段树,AC了,那么应该是没有负数的。

线段树每个节点保存当前编号的数出现的次数。每次查询从小到大第N-K+1个数(N为当前数的总数)。

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 3778    Accepted Submission(s): 1585


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output
The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input
  
  
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q

Sample Output
  
  
1 2 3
Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
#include<cstdio>
#include<cstring>
#include<iostream>

using namespace std;

#define MAXN 1001000
#define lson l,m,root<<1
#define rson m+1,r,root<<1|1
int n,k;

int node[MAXN<<2];

void push_up(int root)
{
	node[root]=node[root<<1]+node[root<<1|1];
}

void build(int l,int r,int root)
{
	if(l==r)
	{
		node[root]=0;
		return ;
	}
	int m=(l+r)>>1;
	build(lson);
	build(rson);
	push_up(root); 
}

void update(int n,int l,int r,int root)
{
	if(l==r)
	{
		node[root]++;
		return ;
	}
	int m=(l+r)>>1;
	if(n<=m)
		update(n,lson);
	else
		update(n,rson);
	push_up(root);
}

int query(int p,int l,int r,int root)
{
	if(l==r)
	{
		return l;
	}
	int m=(l+r)>>1;
	int ret;
	if(p<=node[root<<1])
		ret=query(p,lson);
	else
		ret=query(p-node[root<<1],rson);
	return ret;
}

void solve()
{
	char a[5];
	int ff;
	build(1,MAXN,1);
	int counts=0;
	for(int i=1;i<=n;i++)
	{
		scanf("%s",a);
		if(a[0]=='I')
		{
		scanf("%d",&ff);
		update(ff,1,MAXN,1);
		counts++;	
		}
		else
		printf("%d\n",query(counts-k+1,1,MAXN,1));
	}
	
}

int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
		solve();
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值