HDU1757 A Simple Math Problem 矩阵乘法

因为

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);

所以根据递推式构造关系构造递推矩阵,与vijos1067的本质一样,注意上方的ai与f(i)是反的,这里我已开始没注意查了一会。

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1641    Accepted Submission(s): 925


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 


 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 


 

Output
For each case, output f(k) % m in one line.
 


 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 


 

Sample Output
  
  
45 104
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#define MAXN 32

using namespace std;

struct Matrix
{
    int size;
    long long modulo;
    long long element[MAXN][MAXN];
    void setSize(int);
    void setModulo(long long);
    Matrix operator* (Matrix);
    Matrix power(int);

};

void Matrix::setSize(int a)
{
    for (int i=0; i<a; i++)
        for (int j=0; j<a; j++)
            element[i][j]=0;
    size = a;
}

void Matrix::setModulo(long long a)
{
    modulo = a;
}

Matrix Matrix::operator* (Matrix param)
{
    Matrix product;
    product.setSize(size);
    product.setModulo(modulo);
    for (int i=0; i<size; i++)
        for (int j=0; j<size; j++)
            for (int k=0; k<size; k++)
            {
                product.element[i][j]+=element[i][k]*param.element[k][j];
                product.element[i][j]%=modulo;
            }
    return product;
}

Matrix Matrix::power(int exp)
{
    Matrix res,A;
    A=*this;
    res.setSize(size);
    res.setModulo(modulo);
    for(int i=0;i<size;i++)
        res.element[i][i]=1;
    while(exp)
    {
        if(exp&1)
            res=res*A;
        exp>>=1;
        A=A*A;
    }
    return res;
}

int k,m;
long long a[11];
long long f[11];
Matrix ma;

int main()
{
    while(~scanf("%d%d",&k,&m))
    {
        for(int i=0;i<10;i++)
            scanf("%lld",&a[i]);
        for(int i=0;i<10;i++)
            f[i]=9-i;
        ma.setSize(10);
        ma.setModulo(m);
        for(int i=1;i<10;i++)
            ma.element[i-1][i]=1;
        for(int i=0;i<10;i++)
            ma.element[i][0]=a[i];
        if(k<=9)
            printf("%lld\n",f[k]);
        else
        {
            ma=ma.power(k-9);
            long long ans=0;
            for(int i=0;i<10;i++)
                ans=(ans+f[i]*ma.element[i][0])%m;
            printf("%lld\n",ans%m);
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值