lcm(A,B)=C
已知A和C求B,已知lcm=A*B/GCD
先将C除于A发现对于B而言我们多除了一个GCD 然后就求出多除的因子,然后乘回去就可以了
Benefit
Recently
Yaghoub is playing a new trick to sell some more. When somebody gives him
A Tomans, he who never has appropriate changes, asks for
B Tomans such that lowest common multiple of
A and
B equals to
C and he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.
Benefit |
You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students' benefit which is the lowest of them.
Input
The first line begin with an integer
T (
T100000), the number of tests. Each test that comes in a separate line contains two integers
Aand
C (
1A, C107).
Output
Print the lowest integer
B such that
LCM(A, B) = C in a single line. If no such integer exists, print "
NO SOLUTION" instead. (Quotes for clarity)
Sample Input
3 2 6 32 1760 7 16
Sample Output
3 55 NO SOLUTION
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
typedef long long LL;
LL a,b,c;
LL gcd(LL a,LL b)
{
return b==0?a:gcd(b,a%b);
}
int main()
{
int t;
cin>>t;
while(t--)
{
cin>>a>>b;
if(b%a!=0)
cout<<"NO SOLUTION"<<endl;
else
{
c=b/a;
LL g=c;
while(g!=1)
{
g=gcd(c,a);
c*=g;
a/=g;
}
cout<<c<<endl;
}
}
return 0;
}