UVA10054 The Necklace 欧拉回路输出路径

一个珠子当做一条边,颜色当做一个点,建立无向图,判断存不存一条欧拉回路。


Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

Download as PDF


  Problem D: The Necklace 

My little sister had a beautiful necklace made of colorful beads. Two successive beads in the necklace shared a common color at their meeting point. The figure below shows a segment of the necklace:

But, alas! One day, the necklace was torn and the beads were all scattered over the floor. My sister did her best to recollect all the beads from the floor, but she is not sure whether she was able to collect all of them. Now, she has come to me for help. She wants to know whether it is possible to make a necklace using all the beads she has in the same way her original necklace was made and if so in which order the bids must be put.

Please help me write a program to solve the problem.

Input 

The input contains T test cases. The first line of the input contains the integer T.

The first line of each test case contains an integer N ( $5 \leN \le 1000$) giving the number of beads my sister was able to collect. Each of the next N lines contains two integers describing the colors of a bead. Colors are represented by integers ranging from 1 to 50.

Output 

For each test case in the input first output the test case number as shown in the sample output. Then if you apprehend that some beads may be lost just print the sentence ``some beads may be lost" on a line by itself. Otherwise, print N lines with a single bead description on each line. Each bead description consists of two integers giving the colors of its two ends. For $1 \le i \le N ­ 1$, the second integer on line imust be the same as the first integer on line i + 1. Additionally, the second integer on line N must be equal to the first integer on line 1. Since there are many solutions, any one of them is acceptable.

Print a blank line between two successive test cases.

Sample Input 

2
5
1 2
2 3
3 4
4 5
5 6
5
2 1
2 2
3 4
3 1
2 4

Sample Output 

Case #1
some beads may be lost
 
Case #2
2 1
1 3
3 4
4 2
2 2



#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>

using namespace std;

struct data
{
    int l,r;
}z[2200];

struct node
{
    int v,id,next;
}edge[101100];

bool vis[101100];
int head[100],en;
int set[100];
int n;
int path[101100],top;
int deg[100];

void add(int u,int v,int id)
{
    edge[en].v=v;
    edge[en].id=id;
    edge[en].next=head[u];
    head[u]=en++;

    edge[en].v=u;
    edge[en].id=id^1;
    edge[en].next=head[v];
    head[v]=en++;
}

void init()
{
	for(int i=0;i<100;i++)
		set[i]=i;
}


int find(int a)
{

	int root=a;
	int temp;
	while(set[root]!=root)
		root=set[root];
	while(set[a]!=root)
	{
		temp=a;
		a=set[a];
		set[temp]=root;
	}
	return root;
}


bool merge(int a,int b)
{
	int x=find(a);
	int y=find(b);
	if(x==y)
		return false;
	set[x]=y;
	return true;
}

void dfs(int u)
{
    for(int i=head[u];i!=-1;i=edge[i].next)
        if(!vis[edge[i].id] && !vis[edge[i].id^1])
        {
            vis[edge[i].id]=1;
            vis[edge[i].id^1]=1;
            dfs(edge[i].v);
            path[top++]=edge[i].id;
        }
}

bool eluer()
{
    init();
    for(int i=0;i<60;i++)
        for(int j=head[i];j!=-1;j=edge[j].next)
            merge(i,edge[j].v);
    int st=-1;
    for(int i=0;i<60;i++)
        if(head[i]!=-1)
        {
            if(deg[i]%2==1) return false;
            if(st==-1) st=i;
            if(find(st)!=find(i)) return false;
        }
    top=0;
    memset(vis,0,sizeof(vis));
    if(st!=-1) dfs(st);
    return true;

}

int main()
{
    int t;
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        if(k!=1) printf("\n");
        scanf("%d",&n);
        memset(head,-1,sizeof(head));
        memset(deg,0,sizeof(deg));
        en=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&z[i*2].l,&z[i*2].r);
            z[(i*2)^1].l=z[i*2].r,z[(i*2)^1].r=z[i*2].l;
            add(z[i*2].l,z[i*2].r,i*2);
            deg[z[i*2].l]++;
            deg[z[i*2].r]++;
            
        }
        printf("Case #%d\n",k);
        if(!eluer())
            printf("some beads may be lost\n");
        else
        {
            for(int i=top-1;i>=0;i--)
                    printf("%d %d\n",z[path[i]].l,z[path[i]].r);
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值