树链剖分+线段树,水题。
1036: [ZJOI2008]树的统计Count
Time Limit: 10 Sec Memory Limit: 162 MBSubmit: 3097 Solved: 1282
[ Submit][ Status][ Discuss]
Description
一棵树上有n个节点,编号分别为1到n,每个节点都有一个权值w。 我们将以下面的形式来要求你对这棵树完成一些操作: I. CHANGE u t : 把结点u的权值改为t II. QMAX u v: 询问从点u到点v的路径上的节点的最大权值 III. QSUM u v: 询问从点u到点v的路径上的节点的权值和 注意:从点u到点v的路径上的节点包括u和v本身
Input
输入的第一行为一个整数n,表示节点的个数。 接下来n – 1行,每行2个整数a和b,表示节点a和节点b之间有一条边相连。 接下来n行,每行一个整数,第i行的整数wi表示节点i的权值。 接下来1行,为一个整数q,表示操作的总数。 接下来q行,每行一个操作,以“CHANGE u t”或者“QMAX u v”或者“QSUM u v”的形式给出。 对于100%的数据,保证1<=n<=30000,0<=q<=200000;中途操作中保证每个节点的权值w在-30000到30000之间。
Output
对于每个“QMAX”或者“QSUM”的操作,每行输出一个整数表示要求输出的结果。
Sample Input
4
1 2
2 3
4 1
4 2 1 3
12
QMAX 3 4
QMAX 3 3
QMAX 3 2
QMAX 2 3
QSUM 3 4
QSUM 2 1
CHANGE 1 5
QMAX 3 4
CHANGE 3 6
QMAX 3 4
QMAX 2 4
QSUM 3 4
1 2
2 3
4 1
4 2 1 3
12
QMAX 3 4
QMAX 3 3
QMAX 3 2
QMAX 2 3
QSUM 3 4
QSUM 2 1
CHANGE 1 5
QMAX 3 4
CHANGE 3 6
QMAX 3 4
QMAX 2 4
QSUM 3 4
Sample Output
4
1
2
2
10
6
5
6
5
16
1
2
2
10
6
5
6
5
16
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
#define INF 0x3ffffff
#define MAXN 60010
struct node
{
int to,next;
}edge[9999999];
int head[MAXN],en;
int belong[MAXN],idx[MAXN],qid[MAXN],fi[MAXN],f[MAXN],a[MAXN];
int top[MAXN],len[MAXN];
int dep[MAXN],fat[MAXN],size[MAXN];
int Q[MAXN],vis[MAXN];
int n,m,cnt;
void add(int u,int v)
{
edge[en].to=v;
edge[en].next=head[u];
head[u]=en++;
}
void split()
{
int l,r;
memset(dep,-1,sizeof(dep));
l=0;
dep[Q[r=1]=1]=0;
fat[1]=-1;
while(l<r)
{
int x=Q[++l];
vis[x]=0;
for(int y=head[x];y!=-1;y=edge[y].next)
if(dep[edge[y].to]==-1)
{
dep[Q[++r]=edge[y].to]=dep[x]+1;
fat[edge[y].to]=x;
}
}
cnt=0;
for(int i=n;i;i--)
{
int x=Q[i],p=-1;
size[x]=1;
for(int y=head[x];y!=-1;y=edge[y].next)
if(vis[edge[y].to])
{
size[x]+=size[edge[y].to];
if(p==-1||size[edge[y].to]>size[p])
p=edge[y].to;
}
if(p==-1)
{
idx[x]=len[++cnt]=1;
belong[top[cnt]=x]=cnt;
}
else
{
idx[x]=++len[belong[x]=belong[p]];
top[belong[x]]=x;
}
vis[x]=true;
}
}
void getqid()
{
fi[1]=1;
for(int i=2;i<=cnt;i++)
fi[i]=fi[i-1]+len[i-1];
for(int i=1;i<=n;i++)
{
int blo=belong[i];
qid[i]=fi[blo]+len[blo]-idx[i];
f[qid[i]]=i;
}
}
int queryMax(int l,int r,int root,int L,int R);
int querySum(int l,int r,int root,int L,int R);
int func(int x,int y,int ret,int type);
int research(int x,int y,int tp)
{
int ret=tp==0?0:-INF;
while(belong[x]!=belong[y])
{
if(dep[top[belong[x]]]<dep[top[belong[y]]])
swap(x,y);
ret=func(qid[top[belong[x]]],qid[x],ret,tp);
x=fat[top[belong[x]]];
}
if(dep[x]>dep[y]) swap(x,y);
ret=func(qid[x],qid[y],ret,tp);
return ret;
}
int func(int x,int y,int ret,int type)
{
if(type==0)
ret+=querySum(1,n,1,x,y);
else
ret=max(ret,queryMax(1,n,1,x,y));
return ret;
}
#define lson l,m,root<<1
#define rson m+1,r,root<<1|1
int node[MAXN<<2],sum[MAXN<<2];
void push_up(int root)
{
sum[root]=sum[root<<1]+sum[root<<1|1];
node[root]=max(node[root<<1],node[root<<1|1]);
}
void build(int l,int r,int root)
{
if(l==r)
{
sum[root]=node[root]=a[f[l]];
return ;
}
int m=(l+r)>>1;
build(lson);
build(rson);
push_up(root);
}
void update(int l,int r,int root,int a,int d)
{
if(l==r)
{
node[root]=d;
sum[root]=d;
return ;
}
int m=(l+r)>>1;
if(a<=m)
update(lson,a,d);
else
update(rson,a,d);
push_up(root);
}
int queryMax(int l,int r,int root,int L,int R)
{
if(l>=L && r<=R)
return node[root];
int m=(l+r)>>1;
int ret=-INF;
if(L<=m)
ret=max(ret,queryMax(lson,L,R));
if(R>m)
ret=max(ret,queryMax(rson,L,R));
return ret;
}
int querySum(int l,int r,int root,int L,int R)
{
if(l>=L&&r<=R)
return sum[root];
int m=(l+r)>>1;
int ret=0;
if(L<=m)
ret+=querySum(lson,L,R);
if(R>m)
ret+=querySum(rson,L,R);
return ret;
}
int main()
{
while(~scanf("%d",&n))
{
memset(head,-1,sizeof(head));en=0;
for(int i=0;i<n-1;i++)
{
int u,v;
scanf("%d%d",&u,&v);
add(u,v);
add(v,u);
}
split();
getqid();
for(int i=1;i<=n;i++)
scanf("%d",&a[i]);
build(1,n,1);
scanf("%d",&m);
for(int i=0;i<m;i++)
{
int u,v;
char str[20];
scanf("%s",str);
if(strcmp(str,"QMAX")==0)
{
scanf("%d%d",&u,&v);
printf("%d\n",research(u,v,1));
}
else if(strcmp(str,"QSUM")==0)
{
scanf("%d%d",&u,&v);
printf("%d\n",research(u,v,0));
}
else if(strcmp(str,"CHANGE")==0)
{
scanf("%d%d",&u,&v);
update(1,n,1,qid[u],v);
}
}
}
return 0;
}