POJ2796 Feel Good 单调栈

题目要我们求出一个区间这个区间的和与这个区间中最小的数的乘积值要最大。

对于每一个数字我们求出两个值,分别是lst[i],nxt[i],代表在[lst[i],nxt[i]]区间内a[i]最小。

得到这个区间的方法就是单调栈,单调栈中保存数字的位置。按照次序依次入栈,每次入栈的时候与栈顶比较如果小于栈顶则将栈顶元素出栈,并且更新栈顶元素的nxt域(因为当前元素是第一个比栈顶元素小的数字),然后知道栈为空,或者栈顶元素比a[i]小,然后按情况更新lst[i]即可。

然后比较求值即可。


Feel Good
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 8041 Accepted: 2177
Case Time Limit: 1000MS Special Judge

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10 6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>

using namespace std;

#define MAXN 100100

int n,s[MAXN],tp;
int a[MAXN],lst[MAXN],nxt[MAXN];
long long preSum[MAXN];
long long ans;
int al,ar;

void getPos(int i)
{
    lst[i]=i;nxt[i]=-1;
    while(tp!=0 && a[s[tp-1]]>a[i])
        nxt[s[--tp]]=i-1;
    s[tp++]=i;
    if(tp==1) lst[i]=1;
    else lst[i]=s[tp-2]+1;

}


int main()
{
    while(~scanf("%d",&n))
    {
        preSum[0]=0;tp=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            preSum[i]=preSum[i-1]+a[i];
            getPos(i);
        }
        ans=0;
        al=ar=1;
        for(int i=1;i<=n;i++)
        {
            int l=lst[i],r=nxt[i];
            if(r==-1) r=n;
            long long tmp=1;
            tmp=a[i];
            tmp*=(preSum[r]-preSum[l-1]);
            if(tmp>ans)
            {
                ans=tmp;
                al=l,ar=r;
            }
        }
        printf("%lld\n%d %d\n",ans,al,ar);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值