Tickets

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 
Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
Sample Input
2(几组数据)
2(几个人)
20 25(单独买票时间)
40(2人一起买票时间)
1
8
Sample Output
08:00:40 am

08:00:08 am

题意:总共有n个人,给出每个人都得买票的时间,已及相邻两人一起买票的时间,求出n个人买完票所用的最短时间

思路:简单动态规划,状态方程dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[2]);

dp为前i个人买完票所需的最短时间,a为单个人去的时间,b为两人一起去。

感想:状态方程就是在i位之前最优解已确定的情况下求i的最优解

小心:数组越界,初始状态,几个数组下标对应情况。

AC代码:

# include<iostream>
# include<cstdio>
# include<cmath>
using namespace std;


int main()
{
//freopen("in.txt","r",stdin);
int t;
scanf("%d",&t);
for (int ii=0;ii<t;ii++)
{
int n;
scanf("%d",&n);
int a[n+5],b[n+5];
for (int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
for (int i=2;i<=n;i++)
{
scanf ("%d",&b[i]);
}
int dp[n+5];
dp[0]=0;dp[1]=a[1];
for (int i=2;i<=n;i++)
{
dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]);
}
//printf ("%d\n",dp[n]);
int h=8,m=0,s=dp[n];
m=s/60; s=s%60;
h=m/60+h; m=m%60;
printf ("%02d:%02d:%02d am\n",h,m,s);
}
return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值