HDOJ Problem-1002 A + B Problem II(大位数字相加,容器)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 447938    Accepted Submission(s): 86903

 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002

 

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

Sample Input

2

1 2

112233445566778899 998877665544332211

 

Sample Output

Case 1: 1 + 2 = 3

Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 

Author

Ignatius.L

 

Recommend

We have carefully selected several similar problems for you:  1004 1003 1008 1089 1093 

历经了无数次格式错误!!!!

代码如下:

#include<iostream>
#include<string>
#include<vector>
using namespace std;

int main()
{
	int T;
	scanf("%d",&T);
	int k=1;
	while(T--)
	{
		string a,b,a1,b1;
		vector<int> sum;
		if(k>1) printf("\n");
		cin >> a >> b;
		a1=a;b1=b;
		printf("Case %d:\n",k++);
		if(a.size()>b.size())
		{
			b.insert(0,a.size()-b.size(),48);
			//cout << b;
		}
		if(a.size()<b.size())
		{
			a.insert(0,b.size()-a.size(),48);
		//	cout << a;
		}
		
		for(int i=a.size()-1;i>=0;i--)
		{
			int total=a.at(i)+b.at(i)-48*2;
			if(total<10)
			{
				//cout << total <<endl;
				sum.push_back(total);
			}
			else
			{
				sum.push_back(total%10);
				if(i!=0)
					a.at(i-1)+=total/10;
				if(i==0)
					sum.push_back(total/10);
			}
		}
	
		cout << a1 <<" + "<< b1 << " = ";
		for(int i=sum.size()-1;i>=0;i--)
			printf("%d",sum[i]);
		printf("\n");
		//if(k!=T) printf("\n");
	}
	return 0;
 } 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值