A + B Problem II(1002)

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
  
  
2 1 2 112233445566778899 998877665544332211

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 哈哈哈,简不简单?就是计算a+b,别傻了(= =),看看第二个实例就知道了,所以要用字符串模拟加法,不过呢,在这里,我还是要提一下python,2333,10^1000,完全不在话下~ 两行代码搞定2333,不过还是用C做吧2333,我怎么那么想笑呢2333
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 1e3 + 5;
char a[N],b[N],c[N];

void add()
{
    int d[N];
    int p = strlen(a)-1,q = strlen(b)-1;
    int i = 0,left = 0;
    while(p >= 0 || q >= 0)
    {
        d[i] = left;
        if(p >= 0)
            d[i] += a[p--] - '0';
        if(q >= 0)
            d[i] += b[q--] - '0';
        left = d[i] / 10;
        d[i] %= 10;
        i ++;
    }
    if(left > 0)
        d[i++] = left;
    int k = 0;
    while(i > 0)
        c[k++] = d[--i] + '0';
    c[k] = '\0';
}
int main()
{
    int t;
    cin >> t;
    for(int i = 1; i <= t; i++)
    {
        scanf("%s%s",a,b);
        printf("Case %d:\n",i);
        add();
        printf("%s + %s = %s\n",a,b,c);
        if(i < t)
            printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值