【计算几何】POJ 1269 Intersecting Lines

POJ 1269 Intersecting Lines 【传送门】

Intersecting Lines

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20497 Accepted: 8658

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题目大意:这道题目意思很好理解,就是给定T组数,然后给八个数字,分别对应4个坐标。然后前两个一组、后两个一组;判断是否相交(输出交点坐标,余两位小数)、是否平行,或者重叠。输出第一行必须是:IERSECTING LINES OUTPUT、最后一行必须输出:END OF OUTPUT。

解题思路:模板题,直接套模板,然后平行斜率相同,斜率相同就判断其中一点是不是在另一条线上,如果在一条线上,那么两条线重叠,输出LINE,否则输出NONE。斜率不相同一定相交,套用模板即可。

模板链接:https://blog.csdn.net/lesileqin/article/details/96741526

AC代码:

#include<iostream>

using namespace std;
#define eps 1e-9
struct Point{
	double x,y;
	Point(double x=0,double y=0):x(x),y(y){}
};
Point operator - (Point A,Point B)
{
	return Point(A.x-B.x,A.y-B.y);
}

Point operator * (Point A,double p)
{
	return Point(A.x*p,A.y*p);
}

Point operator + (Point A,Point B)
{
	return Point(A.x+B.x,A.y+B.y);
}

Point operator / (Point A,double p)
{
	return Point(A.x/p,A.y/p);
}

double Cross(Point A,Point B)
{
	return A.x*B.y-A.y*B.x;
}

Point GetLineIntersection(Point P,Point v,Point Q,Point w)
{
	Point u=P-Q;
	double t=Cross(w,u)/Cross(v,w);
	return P+v*t;
}

int main()
{
	ios::sync_with_stdio(false);
	int N;
	cin >> N;
	cout << "INTERSECTING LINES OUTPUT\n";
	while(N--)
	{
		double x1,y1,x2,y2,x3,y3,x4,y4;
		cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3 >> x4 >> y4;
		Point p1,p2,p3,p4;
		p1.x=x1,p1.y=y1;
		p2.x=x2,p2.y=y2;
		p3.x=x3,p3.y=y3;
		p4.x=x4,p4.y=y4;
			
		//斜率相同则共线或平行 
		if((p2.x-p1.x)*(p4.y-p3.y)==(p2.y-p1.y)*(p4.x-p3.x))
		{
			//bug
			if((p2.x-p1.x)*(p3.y-p1.y)==(p2.y-p1.y)*(p3.x-p1.x))
			 	cout << "LINE\n";
			else
				cout << "NONE\n";
			//cout << "1\n";
		}
		else{
			Point P=GetLineIntersection(p1,p2-p1,p3,p4-p3);
			printf("POINT %.2lf %.2lf\n",P.x,P.y);
		}
	}
	cout << "END OF OUTPUT\n";
	return 0;
} 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值