【博弈论】HDU 1525 Euclid's Game

Euclid's Game【传送门】

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5556    Accepted Submission(s): 2624

Problem Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

Sample Input

34 12

15 24

0 0

Sample Output

Stan wins

Ollie wins

Source

University of Waterloo Local Contest 2002.09.28

专题链接详解:https://blog.csdn.net/lesileqin/article/details/98525887

AC代码:

#include<iostream> 
#include<cstring>
#include<cstdio>
#include<vector>
#include<cmath>
#include<map>
#include<set>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
#define INF 999999
#define MOD 2009
#define MAXN 1005
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;

int a,b;

void solve(){
	bool flag=true;
	while(true){
		if(a>b) swap(a,b);
		if(b%a==0) break;
		if(b-a>a) break;
		b-=a;
		flag=!flag;
	}
	if(flag) cout << "Stan wins\n";
	else cout << "Ollie wins\n";
}

int main(){
	ios::sync_with_stdio(false);
	while(cin >> a >>b && a && b){
		solve();
	}	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值