Prim: Agri-Net

B - Agri-Net
Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;

const int INF = 1<<31 - 1;

int edges[110][110];
int n;
long long sum;

void Prim(int v){
    int low[110], exist[110];//low表示最小生成树到周围的点最短的距离
    int i, j, k;
    long long min;
    for(i = 0; i < n; i ++){//初始化所有点的状态,和点v所对应的周围的low变长
        exist[i] = 0;
        low[i] = edges[i][v];
    }
    exist[v] = 1;
    sum = 0;
    for(i = 0; i < n - 1; i ++){
        min = INF;
        for(j = 0; j < n; j ++){
            if(0 == exist[j] && min > low[j]){ //在所有low中选择最短的然后把通过其达到的点添加到生成树
                min = low[j];
                k = j;
            }
        }
        exist[k] = 1;//添加该点到生成树中
        v = k;
        sum += min;
        //由于新添加了点,所以生成树到它周围的点们的最短距离发生了变化
        for(j = 0; j < n; j ++){//Prim算法最精妙的在于此处,只要之前的low比现在的变长小都不用更新low
            if(0 == exist[j] && edges[j][v] < low[j])
                low[j] = edges[j][v];
        }
    }
}

int main(){
    int i, j;
    while(~scanf("%d", &n)){
        for(i = 0; i < n; i ++){
            for(j = 0; j < n; j ++){
                scanf("%d", &edges[i][j]);
            }
        }
        Prim(0);
        cout << sum << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值