广搜:Catch That Cow

Catch That Cow

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 57   Accepted Submission(s) : 35
Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
 

Source
PKU

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<queue>

using namespace std;

bool used[100005];          //true 表示这点没有到过
long n,k;
struct point
{
    long x,step;            //x 存位置,step存到这步的步数
};
long bfs(long n,long k)
{
    queue<point>que;
    point tp,ans;
    long tn;
    ans.x=n;
    ans.step=0;
    used[n]=false;
    que.push(ans);
    while(1)
    {
        tp=que.front();
        tn=tp.x+1;              //往前走
        que.pop();
        
        if(tn>=0&&tn<=100000)
        {
            if(used[tn])
            {
                 used[tn]=false;
                 ans.x=tn;
                 ans.step=tp.step+1;
                 que.push(ans);
                 if(ans.x==k)
                     return ans.step;
            }
        }
        tn=tp.x-1;                            //往后走
        if(tn>=0&&tn<=100000)
        {
            if(used[tn])
            {
                used[tn]=false;
                ans.x=tn;
                ans.step=tp.step+1;
                que.push(ans);
                if(ans.x==k)
                    return ans.step;
            }
        }
        tn=2*tp.x;                 //两倍距离
        if(tn>=0&&tn<=100000)
        {
        if(used[tn])
            {
                used[tn]=false;
                ans.x=tn;
                ans.step=tp.step+1;
                que.push(ans);
                if(ans.x==k)
                    return ans.step;
            }
        }
    }
}
int main()
{
    long sum;
    cin>>n>>k;
        if(n>k||n==k)
        cout<<n-k;
        else
        {
            memset(used,true,sizeof(used));
                sum=bfs(n,k);
            cout<<sum;
        }
    
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值