HDU:2717 Catch That Cow(广搜)

6 篇文章 0 订阅

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12317    Accepted Submission(s): 3828


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

Source
 

Recommend
teddy

题目大意:一个农夫在x坐标轴上捉牛,给了那个农夫的坐标,给了那个牛的坐标,那个牛不会动,农夫会动,农夫每次可向前走一步或向后走一步或者向前传送到当前坐标的二倍,问农夫最需要移动几次能捉到牛。
解题思路:广搜,三种状态,但要注意减的时候左区间不能超过0,加或乘的时候不超过题目给的100000.
代码如下:
#include <cstdio>
#include <cstring>
#include <queue>
#define N 100000
using namespace std;
struct node
{
	int pos;
	int step;
};
int visit[100010];
bool check(int x)
{
	if(x<0||x>N||visit[x]==1)//判断是否越界、是否访问过 
	{
		return 0;
	}
	return 1;
}
int main()
{
	int n,k;
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		memset(visit,0,sizeof(visit));
		struct node tmp;
		tmp.pos=n;
		tmp.step=0;
		queue<node>q;
		q.push(tmp);//当前坐标入队 
		visit[n]=1;
		while(!q.empty())
		{
			tmp=q.front();
			q.pop();
			if(tmp.pos==k)
			{
				printf("%d\n",tmp.step);//找到的话就输出,然后break 
				break;
			}
			struct node next=tmp;
			next.pos=tmp.pos+1;//前 
			if(check(next.pos))
			{
				next.step++;
				visit[next.pos]=1;//记得标记 
				q.push(next);
			}
			next=tmp;
			next.pos=tmp.pos-1;//后 
			if(check(next.pos))
			{
				next.step++;
				visit[next.pos]=1;
				q.push(next);
			}
			next=tmp;
			next.pos=tmp.pos*2;//x2
			if(check(next.pos))
			{
				next.step++;
				visit[next.pos]=1;
				q.push(next);
			}
		}
	}
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值