杭电A+B problem1002 (大数)

大数的问题真是一让人头疼的问题。用数组存数,我这个初学者 学着好困难。 哭打了好长时间才把代码整好,纪念一下。
 
 
 
 
 
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
 
代码:
#include<stdio.h>
#include<string.h>
#define MAX 1000
int a1[MAX+10];
int a2[MAX+10];
char b1[MAX+10];
char b2[MAX+10];
int main(void)
{
    int n,lenb1,lenb2,i,j,t,k=1;
    scanf("%d",&n);
    getchar();
    //scanf("%s %s",b1,b2);
    while(n--)
    {
        scanf("%s %s",b1,b2);
        getchar();
        //lenb1=strlen(b1);
        //lenb2=strlen(b2);
        memset(a1,0,sizeof(a1));
        memset(a2,0,sizeof(a2));
        lenb1=strlen(b1);
        for(j=0,i=lenb1-1;i>=0;i--)
        {
           a1[j++]=b1[i]-'0';
        }
        lenb2=strlen(b2);
        for(j=0,i=lenb2-1;i>=0;i--)
        {
            a2[j++]=b2[i]-'0';
        }
        if(lenb1<lenb2)
        {
             t=lenb1;lenb1=lenb2;lenb2=t;
        }
        for(i=0;i<lenb1;i++)
        {
           a1[i]+=a2[i];
           if(a1[i]>=10)
           {
              a1[i]-=10;
              a1[i+1]++;
           }
        }
        printf("Case %d:\n",k++);
        //k++;
        printf("%s + %s = ",b1,b2);
        if(a1[lenb1]!=0)
            printf("%d",a1[lenb1]);
        for(i=lenb1-1;i>=0;i--)
            printf("%d",a1[i]);
        printf("\n");
        if(n)
            printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值