Text Reverse hdoj 1062

/*
Text Reverse

http://acm.hdu.edu.cn/showproblem.php?pid=1062

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16647    Accepted Submission(s): 6331


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
 

Sample Output
hello world!
I'm from hdu.
I like acm.

Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:  1073 1088 1113 1043 1200
*/

看实例就知道要干嘛的。。。不过还是花了我一点工夫奋斗奋斗
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define M 1000
char s[M];
char a[M];
int main()
{
 int T;
 scanf("%d",&T);
 getchar();   //这个还是不能忘啊!
 while(T--)
 {
  memset(s,0,sizeof(s));
  gets(s);
  int i,j,k,len;
  len=strlen(s);
  
  memset(a,0,sizeof(a));
    
  for(i=0;i<len;)
  {
   
    /*
    j=0;
   int t=i;
   while((s[t]!=' '))
    {
     a[j++]=s[t];
     t++;
    }
     */

  if(s[i]==' ')
   {
    
   printf(" ");
   i++; 
   }
    else
     {
       j=0;
       int t=i;
     while((s[t]!=' ')&&s[t]!='\0')//把每个单词存储起来,存储一个,输出一个;
      {
       a[j++]=s[t];
       t++;
      }
     int p=j;
     for(k=p-1;k>=0;k--)
      printf("%c",a[k]);
      i+=p;这一步至关重要,我想了好久,不是i++;因为这个过程中你用掉了一个单词的长度;
     }
   
  }
  printf("\n");
 }
 return 0;
}

 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值