hdoj 1312 Red and Black (DFS)

110 篇文章 0 订阅
6 篇文章 0 订阅

Red and Black

http://acm.hdu.edu.cn/showproblem.php?pid=1312
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10361    Accepted Submission(s): 6472


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1010 1372 1242 1253 1240 

#include<cstdio>

#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
char map[25][25];
int visit[25][25];
int fx[4]={1,0,-1,0};
int fy[4]={0,1,0,-1};
int w,h,step;
void DFS(int i,int j)
{
  int k;
  for(k=0;k<4;k++)
  {
  int x=fx[k]+i;
  int y=fy[k]+j;
  if(x>=0&&y>=0&&x<h&&y<w&&map[x][y]=='.')
  {
  step++;
map[x][y]='#';
  DFS(x,y);
}

  }
}
int main()
{
while(scanf("%d%d",&w,&h),(w||h))
{
int i,j,k;
step=1;
for(i=0;i<h;i++)
 scanf("%s",map[i]);
 
 for(i=0;i<h;i++)
   for(j=0;j<w;j++)
     if(map[i][j]=='@')
       DFS(i,j);

 printf("%d\n",step);
}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值