hdoj 1081 To The Max

110 篇文章 0 订阅
24 篇文章 0 订阅

To The Max

http://acm.hdu.edu.cn/showproblem.php?pid=1081
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8989    Accepted Submission(s): 4356


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 

Source
 

Recommend
We have carefully selected several similar problems for you:  1024 1025 1080 1078 1074 

//常见的矩阵压缩,将二维的矩阵压缩成一维矩阵,然后按照最大子序列问题来处理

#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
int a[110][110];
int dp[10010];


int main()
{
 int n;
 while(~scanf("%d",&n))
 {
     int i,j,k,M;
     for(i=1;i<=n;i++)
       for(j=1;j<=n;j++)
        scanf("%d",&a[i][j]);    
      
      M=-1000000;
      for(i=1;i<=n;i++)
      {
          memset(dp,0,sizeof(dp));
          for(j=i;j<=n;j++)
          {
            for(k=1;k<=n;k++)
              dp[k]+=a[j][k];

              int sum=0;
            for(k=1;k<=n;k++)//这部分就是传说中的最大子序列问题常见算法
            {
              if(sum>0)
             sum+=dp[k];
            else
              sum=dp[k];
           if(sum>M)
             M=sum;
          }

         }
      }
      printf("%d\n",M);
 }
 return 0;    


//

其他的人算法:感觉挺高深的

常见的矩阵压缩,将二维的矩阵压缩成一维矩阵,然后按照最大子序列问题来处理

扩展到二维的时候也是同样的方法,不过需要将二维压缩成一维,所以我们要将数据做一下处理,使得map[i][j]从表示第i行第j个元素变成表示第i行前j个元素和,这样map[k][j]-map[k][i]就可以表示第k行从i->j列的元素和。只要比一维多两层循环枚举i和j就行了。

#include <iostream>

#define MAX 101
using namespace std;
int map[MAX][MAX];
int main()
{
    int n, i, j, temp, k;
    
    while(scanf("%d", &n) != EOF)
    {
        memset(map, 0, sizeof(map));
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
            {
                scanf("%d", &temp);
                map[i][j] += map[i][j - 1] + temp;//这里表示第i行的前j列之和
            }

        int max = -100000;
        for(i = 1; i <= n; i++)
            for(j = i; j <= n; j++)
            {

                int sum = 0;
                for(k = 1; k <= n; k++)
                {
                    if(sum < 0)
                        sum = 0;
                    sum += map[k][j] - map[k][i  - 1];//这里表示前k行,i->j列之和
                    if(sum > max)
                        max = sum;
                }

            }
        printf("%d\n", max);
    }
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值