HDOJ 1081 To The Max(矩阵DP)

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
4  
0 -2 -7 0 
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
 

Sample Output
15
本题的题意是给一个数字矩阵,求出这个矩阵中和最大的小矩阵(可以包括这个大矩阵)
这题的思路是遍历所有的矩阵求出最大的和的矩阵  
方法如下:
样例中 0 -2 -7  0
            9  2  -6  2
           -4 1 -4 1
           -1 8 0 -2可以每个数字向右相加变成
           0 -2 -9 -9
           9 11 5 7
           -4 -3 -7 -6
            -1 7 7  5  
 在这个矩阵中每个数字表示的是此行的数相加到这个数的和
每个竖排的数相加就是所关联的数的矩阵
所以遍历所有的竖排的数相加便能得出每个矩阵的和
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define N 100
int a[N][N];

int  find(int n) 
{
	int i,j,MAX,k,s;
	MAX=-1000;
	
	for(i=1;i<=n;i++)
	 for(j=i;j<=n;j++)
	 {
	 	s=0;
	 	for(k=1;k<=n;k++)
	 	 {
		  if(s<=0) s=0;
	 	 	s+=a[k][j]-a[k][i-1];
			if(s>MAX)  MAX=s;
		  }
	 }
	
	return MAX;
}
int main()
{
	int n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
	memset(a,0,sizeof(a));
	for(i=1;i<=n;i++)
	 for(j=1;j<=n;j++)
	 {
	 cin>>a[i][j];
	 a[i][j]+=a[i][j-1];
    }
	 printf("%d\n",find(n));
     }
	 return 0;
}

从而求出最大的和
代码如下:

       


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值