hdoj1081 To The Max

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10467    Accepted Submission(s): 5026


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 
参考:http://blog.sina.cn/dpool/blog/s/blog_87d81ad00100v9g9.html  

解题思路:
1.想到最大子序列问题
2.将矩阵压缩:把多行每一列压缩成一维数组,形成一个1行n列的一维数组。
   从第一行开始逐个往下压缩,每压缩一次,将它看成最大子序列问题进行比较得出最大。
   逐个遍历整个数组。O(n^3).


#include <stdio.h>
#include <string.h>
int dp_subsequence(int dp[],int n)//求最大子序列
{
    int i,max=dp[0],sum = dp[0];
    for(i=1;i<n;i++)
    {
        if(sum > 0)
            sum += dp[i];
        else
            sum = dp[i];
        if(sum > max)
            max = sum;
    }
    return max;
}
int main()
{
    int n,i,j,k,a[200][200],dp[200];
    while(scanf("%d",&n)!=EOF && n!=0)
    {
        memset(dp,0,sizeof(dp));
        int sum,max = -9999999;
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                scanf("%d",&a[i][j]);
        for(i=0;i<n;i++)//遍历行
        {
            for(j=i;j<n;j++)//控制压缩时的行
            {
                for(k=0;k<n;k++)//控制压缩时的列
                {
                   dp[k] += a[j][k];//压缩数组
                }
                sum = dp_subsequence(dp,n);//得出当前压缩的数组最大子序列值
                if(max < sum)//如果比之前的大,进行替换,否则保持
                    max = sum;
            }
            memset(dp,0,sizeof(dp));//当计算完一轮需要将压缩数组归0以便进行下一轮的压缩
        }
        printf("%d\n",max);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值