Description
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.
Input
Line 1: Three space-separated integers: N, M, and R
Lines 2..M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi
Output
Line 1: The maximum number of gallons of milk that Bessie can product in the N hours
Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
一个dp,区间dp算是吧,就是在区间上找到挤牛奶最多的,区间不能有重叠。
动态转移方程
dp[i]=max(dp[a[j].s-r]+a[j].c,dp[i])
测试数据dp结果
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m,r;
struct data
{
int s,e,c;
bool operator<(const data &x) const
{
if(e!=x.e) return e<x.e;
return s<x.s;
}
};
data a[1005];
int dp[1000005];
int sum;
int main()
{
while(scanf("%d%d%d",&n,&m,&r)!=EOF)
{
sum=0;
for(int i=0;i<m;i++)
scanf("%d%d%d",&a[i].s,&a[i].e,&a[i].c);
sort(a,a+m);
memset(dp,0,sizeof(dp));
int j=0;
for(int i=1;i<=n;i++)
{
while(a[j].e==i&&j<m)
{
if(a[j].s-r<=0)
dp[i]=max(dp[i],a[j].c);
else
dp[i]=max(dp[a[j].s-r]+a[j].c,dp[i]);
j++;
}
dp[i]=max(dp[i],dp[i-1]);
}
printf("%d\n",dp[n]);
}
return 0;
}