数据结构实验之链表三:链表的逆置

数据结构实验之链表三:链表的逆置

Time Limit: 1000MSMemory Limit: 65536KB
Problem Description
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。
Input
输入多个整数,以-1作为结束标志。
Output
输出逆置后的单链表数据。
Example Input
12 56 4 6 55 15 33 62 -1
Example Output
62 33 15 55 6 4 56 12
Hint
不得使用数组。 

//C语言
#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};


struct node *creat(int x)
{
    struct node *p,*head;
    head=(struct node*)malloc(sizeof(struct node));
    head->next=NULL;


    p=(struct node*)malloc(sizeof(struct node));
    p->next=NULL;
    while(scanf("%d",&p->data)!=EOF&&p->data!=-1)
    {
        p->next=head->next;
        head->next=p;


        p=(struct node*)malloc(sizeof(struct node));
        p->next=NULL;
    }
    return (head);
};


void print(struct node *h)
{
    struct node *s=h->next;
    while(s!=NULL)
    {
        if(s->next==NULL)
            printf("%d\n",s->data);
        else
            printf("%d ",s->data);
        s=s->next;
    }
}


int main()
{
    struct node *p=creat(1);
    print(p);
    return 0;
}


//C++

#include <iostream>


using namespace std;


typedef struct node
{
    int data;
    node *next;
};
node *create()
{
    node *head,*p;
    head=new node;
    head->next=NULL;
    while(1)
    {
        p=new node;


        cin>>p->data;
        if(p->data==-1)
            break;
        p->next=head->next;
        head->next=p;
    }
    delete p;
    return head;


}


void print(node *h)
{
    node *p;
    p=h->next;
    while(p!=NULL)
    {
        cout<<p->data;
        if(p!=NULL)
            cout<<" ";
        p=p->next;
    }
    cout<<endl;
}


int main()
{
    node *h;
    h=create();
    print(h);
    delete h;
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值