数据结构实验之链表六:有序链表的建立

数据结构实验之链表六:有序链表的建立

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。
Input
第一行输入整数个数N;
第二行输入N个无序的整数。
Output
依次输出有序链表的结点值。
Example Input
6
33 6 22 9 44 5
Example Output
5 6 9 22 33 44
Hint
不得使用数组! 

#include <iostream>

using namespace std;
typedef struct node
{
int data;
node *next;
};

node *create(int n)
{
node *head,*p,*tail;
head=new node;
head->next=NULL;
tail=head;
for(int i=0;i<n;i++)
{
p=new node;
p->next=NULL;
cin>>p->data;
tail->next=p;
tail=p;
}
return head;
}
void paixu(node *head,int n) //类似于选择排序法
{
node *p,*q;
int t;
for(p=head->next;p!=NULL;p=p->next)
{
for(q=p->next;q!=NULL;q=q->next)
{
if(p->data>q->data)
{
t=p->data;
p->data=q->data;
q->data=t;
}
}
}
}

void print(node *p)
{
node *h=p->next;
while(h)
{
cout<<h->data;
if(h->next!=NULL)
cout<<" ";
h=h->next;
}
cout<<endl;
}
int main()
{
int n;
cin>>n;
node *p;
p=create(n);

paixu(p,n);
print(p);
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值