模拟_1150 Travelling Salesman Problem

该博客介绍了旅行商问题的背景和复杂性,并提供了一个具体的实例来解决这个问题。通过给定的城市和边的列表,我们需要找到最接近旅行商问题解决方案的循环路径。输入包括城市数量、边的数量以及一系列可能的路径。输出包括每个路径的总距离,以及对路径类型的分类。最终,博客给出了最接近解决方案的循环路径及其总距离。
摘要由CSDN通过智能技术生成

目录

1150 Travelling Salesman Problem

题目描述

解题思路

程序


1150 Travelling Salesman Problem

题目描述

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

解题思路

给出N条路径,要求求出每一条路径的长度,如果路径中有不通的路,则输出NA,以及判断他们是否经过图中所有的点,并且路径回到起点,如果没有经过图中所有的点、存在不通的路、或者没有回到起点,则输出(Not a Ts cycle),如果经过每一个点,回到起点没有做多余的路,(只包含一个简单的回路),则输出(TS simple cycle),如果不只包含一个简单的回路,则输出(TS cycle)

最后输出经过左右点并且回到起点的路中,最短的路编号以及长度

区分(TS simple cycle)和(TS cycle),可以使用unordered_set记录路径中节点的个数,如果数量等于M+1(没有经过多余的节点),则为(TS simple cycle),如果超出M+1,则为(TS cycle)

程序

#include <iostream>
#include <initializer_list>
#include <algorithm>
#include <string>
#include <string.h>
#include <thread>
#include <cmath>
#include <vector>
#include <unordered_map>
#include <unordered_set>
#define INF 0x3f3f3f3f

using namespace std;
const int maxn = 205;
int N,M,K;
int mapp[maxn][maxn];

int main()
{
    int x,y,d;
    scanf("%d%d",&N,&M);
    for(int i =0;i < M;i ++)
    {
        scanf("%d%d%d",&x,&y,&d);
        mapp[x][y] = d;mapp[y][x] = d;
    }
    scanf("%d",&K);
    int test = 1,dis,index,shortest = INF,first;
    unordered_set<int> s;
    while(K--)
    {
        bool flag = false;
        s.clear();
        dis = 0;
        scanf("%d",&x);
        scanf("%d",&d); first = d;
        s.insert(d);
        for(int i = 1;i < x;i ++)
        {
            scanf("%d",&y);
            if(mapp[d][y] == 0)
                flag = true;
            else
                dis += mapp[d][y];
            s.insert(y);
            d = y;
        }
        if(flag)
            printf("Path %d: NA (Not a TS cycle)\n",test++);
        else
        {
            printf("Path %d: %d ",test++,dis);
            if(s.size() != N || first != y)
                printf("(Not a TS cycle)\n");
            else if(s.size() == N && first == y && x == N+1)
            {
                printf("(TS simple cycle)\n");
                if(dis < shortest)
                    shortest = dis,index = test-1;
            }

            else if(s.size() == N && first == y && x > N+1)
            {
                printf("(TS cycle)\n");
                if(dis < shortest)
                    shortest = dis,index = test-1;
            }
        }
    }
    printf("Shortest Dist(%d) = %d\n",index,shortest);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值