(Maximum Subsequence Sum )最大子列输出问题

 

 

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j(as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

 

注意:

1.如果输入的元素全为负数,则最大和为0,同时输出首尾的负数。

2.如果输入元素全为负数和0,则最大和为0,但输出应该是0 0 0. 比如输入-8 0 -9,输出是0 0 0,而不是0 -8 -9。

3.输出的首尾元素应该具有最小下标,比如: 输入2 4 -6 7,则应输出7 2 7,而不是7 7 7。

4.如果最大子序列不是唯一的,则输出具有最小索引i和j的子序列,比如:输入1  2 -3 2 1,应该输出3 1 2 ,而不是3 2 1。

#include <stdlib.h>
#include <stdio.h>
int main()
{

	int i,j,N;
	int ThisSum = 0,MaxSum = 0;
	int temp_l = 0,temp_e = 0,log = 0;
	int a[10000];
	scanf("%d",&N);
	j = N;
	for(i=0;i<N;i++)
	{
		scanf("%d",&a[i]);
	}
	for(i = 0;i < N;i++)
	{
		ThisSum += a[i];
		if(MaxSum < ThisSum)
		{
			MaxSum = ThisSum;
			temp_l = log;
			temp_e = i;
		}
		if(ThisSum < 0)
		{
			ThisSum = 0;
			log = i + 1;           //当出现当前和小于0,标志位指向下一个数
			j--;                   //如果j=0;说明所有数都是负数
		}
	}
	if(MaxSum==0)
	{
		if(j==0)
		{
			printf("0 %d %d\n",a[0],a[N-1]);
		}
		else
		{
			printf("0 0 0\n");	
		}
		
	}
	else
	{
		printf("%d %d %d\n",MaxSum,a[temp_l],a[temp_e]);
	}
	system("pause");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值