Two HDU - 5791 (DP)

Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A’ and sequence B’ are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A’ is a subsequence of A. B’ is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.
Input
The input contains multiple test cases.

For each test case, the first line cantains two integers N,M(1≤N,M≤1000)N,M(1≤N,M≤1000). The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
Output
For each test case, output the answer mod 1000000007.
Sample Input
3 2
1 2 3
2 1
3 2
1 2 3
1 2
Sample Output
2
3
dp题,原型是最长公共子序列,只不过这个要求个数。
状态:

dp[x][y]:a1xb1y

状态转移方程:
a[x]=b[y]dp[x][y]=dp[x][y1]+dp[x1][y]+1
dp[x][y]=dp[x][y1]+dp[x1][y]dp[x1][y1]

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define mod 1000000007
using namespace std;
int n,m;
int dp[1003][1003];
int a[1003],b[1003];
int solve(int x,int y)
{
    if(dp[x][y]!=-1)
        return dp[x][y];
    if(a[x]==b[y])
        return dp[x][y]=(solve(x,y-1)+solve(x-1,y)+1)%mod;
    int temp=solve(x,y-1)+solve(x-1,y)-solve(x-1,y-1);
    if(temp<0)
        return dp[x][y]=(temp+mod)%mod;
    else
        return dp[x][y]=temp%mod;
}
int main()
{
    while(scanf("%d%d",&n,&m)==2)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",a+i);
        for(int i=1;i<=m;i++)
            scanf("%d",b+i);
        memset(dp,-1,sizeof(dp));
            for(int i=0;i<=1000;i++)
        dp[i][0]=0,dp[0][i]=0;
        printf("%d\n",solve(n,m));
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值