PAT甲级1040. Longest Symmetric String (25)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given “Is PAT&TAP symmetric?”, the longest symmetric sub-string is “s PAT&TAP s”, hence you must output 11.
Input Specification:
Each input file contains one test case which gives a non-empty string of length no more than 1000.
Output Specification:
For each test case, simply print the maximum length in a line.
Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11

暴力法:分两种情况 1)最长回文串长度为奇数:以字符串中的所有单个字符串为中心,往两边扩散找最长的;2)最长回文串长度为偶数:以字符串中出现的成对字符串为中心,往两边扩散找最长的。
此题还可以用动态规划法:http://blog.csdn.net/tuzigg123/article/details/47053481

#include <iostream>
using namespace std;
#include <string>

int main(){
    string str;
    getline(cin,str);//注意事项:有空格要用getline 

    int maxLen=0;
    int currentLen=0;
    int j=0;
    /*奇数的情况*/
    for(int i=0;i<str.length();i++){
        currentLen=1;
        j=1;
        while(i-j>=0&&i+j<str.length()){
            if(str[i+j]==str[i-j]) {
                currentLen+=2;
                j++;
            }
            else break;
        }
        if(currentLen>maxLen) maxLen=currentLen;
    }
    /*偶数的情况*/ 
    for(int i=0;i<str.length()-1;i++){
        if(str[i]!=str[i+1]) continue;
        currentLen=2;
        j=1;
        while(i-j>=0&&i+1+j<str.length()){
            if(str[i-j]==str[i+1+j]) {
                currentLen+=2;
                j++;
            }
            else break;
        }
        if(currentLen>maxLen) {
            maxLen=currentLen;
        }
    }

    cout<<maxLen;

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值