The task is simple: given any positive integer N, you are supposed to count the total number of ones in the decimal form of the integers from 1 to N. For example, given N being 12, there are five ones in 1, 10, 11, and 12.
Input Specification:
Each input file contains one test case which gives the positive N (<=
230
).
Output Specification:
For each test case, print the number of 1’s in one line.
Sample Input:
12
Sample Output:
5
//看了别人的才知道。很巧妙的方法
#include <iostream>
using namespace std;
int main(){
int N;
cin>>N;
int count=0;
int x=1;
while(N/x>0){
int current=(N/x)%10;
int left=N/(10*x);
int right=N%x;
if(current<1) count+=left*x;
else if(current==1) count+=(left*x+right+1);
else count+=(left+1)*x;
x*=10;
}
cout<<count<<endl;
return 0;
}