ZOJ3551:Bloodsucker(概率DP)

n 0th day, there are n-1 people and 1 bloodsucker. Every day, two and only two of them meet. Nothing will happen if they are of the same species, that is, a people meets a people or a bloodsucker meets a bloodsucker. Otherwise, people may be transformed into bloodsucker with probability p. Sooner or later(D days), all people will be turned into bloodsucker. Calculate the mathematical expectation of D.

Input

The number of test cases (TT ≤ 100) is given in the first line of the input. Each case consists of an integer n and a float number p (1 ≤ n < 100000, 0 < p ≤ 1, accurate to 3 digits after decimal point), separated by spaces.

Output

For each case, you should output the expectation(3 digits after the decimal point) in a single line.

Sample Input
1
2 1

Sample Output
1.000
 
题意:一共有n个人,每天都会有一个人又一定的几率变成吸血鬼,求所有人变成吸血鬼的期望
思路:概率DP,我们可以逆推,dp[i]代表i个人到所有人变成吸血鬼的概率,往上逆推

则:dp[i]=(dp[i+1]+1)*p1+(dp[i]+1)*p2

移项后化简得: p1*dp[i]=dp[i+1]*p1+1

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

double dp[100005];

int main()
{
    int T,n,i;
    double p;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%lf",&n,&p);
        dp[n] = 0;
        for(i = n-1; i>=1; i--)
        {
            double s1,s2,p1;
            s1 = (double)n*(n-1)/2;//从n个人中选两个人出来的选法,也就是C(n,2)
            s2 = (double)i*(n-i);//i为从i个人中选出一人的方法,n-i为从吸血鬼中选出一个吸血鬼的总数,共有这么多种
            p1 = s2/s1*p;//人与吸血鬼相遇的概率
            dp[i] = (dp[i+1]*p1+1)/p1;
        }
        printf("%.3f\n",dp[1]);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值