zoj 3551 Bloodsucker

 

In 0th day, there are n-1 people and 1 bloodsucker. Every day, two and only two of them meet. Nothing will happen if they are of the same species, that is, a people meets a people or a bloodsucker meets a bloodsucker. Otherwise, people may be transformed into bloodsucker with probability p. Sooner or later(D days), all people will be turned into bloodsucker. Calculate the mathematical expectation ofD.

Input

The number of test cases (T, T ≤ 100) is given in the first line of the input. Each case consists of an integern and a float numberp (1 ≤n < 100000, 0 <p ≤ 1, accurate to 3 digits after decimal point), separated by spaces.

Output

For each case, you should output the expectation(3 digits after the decimal point) in a single line.

Sample Input
1 
2 1
Sample Output
1.000
 
 

一道概率题,可以这样考虑: 根据题意,每天只能增加一个Bloodsucker,也就是说n-1个正常人是一个接着一个变成Bloodsucker的,那么所有正常人变成Bloodsucker的天数期望等于所有正常人变成Bloodsucker的天数期望之和。考虑n-1个正常人中第i个变成Bloodsucker的正常人的转变概率为:

P[i] = i*(n-i)/(n*(n-1)/2)
则天数期望为(直接从概率的定义考虑):
D[i] = 1/P[i]
于是:
D = sum(D[i])
 
 
 

代码如下
#include <stdio.h>



int main() {

    int T;

    int n;

    double p;

    scanf("%d", &T);

    while(T--) {

    scanf("%d %lf", &n, &p);

    

    double res = 0;

    double tmp = n*0.5*(n-1)/p;

    int i;

    for( i=1; i<=(n-1)/2; i++) {

     res += tmp/i/(n-i);

    }

    res *= 2;

    res += (n%2==0)?(4*tmp/n/n):0;

    

    printf("%.3lf\n", res);



    }

    return 0;

}

原文链接 http://blog.chinaunix.net/space.php?uid=26372629&do=blog&id=2996052
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值