HDU4608:I-number

Problem Description
The I-number of x is defined to be an integer y, which satisfied the the conditions below:
1.  y>x;
2.  the sum of each digit of y(under base 10) is the multiple of 10;
3.  among all integers that satisfy the two conditions above, y shouble be the minimum.
Given x, you're required to calculate the I-number of x.
 

Input
An integer T(T≤100) will exist in the first line of input, indicating the number of test cases.
The following T lines describe all the queries, each with a positive integer x. The length of x will not exceed 10 5.
 

Output
Output the I-number of x for each query.
 

Sample Input
  
  
1 202
 

Sample Output
  
  
208
 


一道简单多校题,找出比给定数大,且各位数之和能整除10的最小的数,因为时间给得十分充裕,直接暴力

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

char str[100005],c[100005];

void add(char a[],char b[],char back[])
{
    int i,j,k,up,x,y,z,l;
    if(strlen(a) > strlen(b))
        l = strlen(a)+2;
    else
        l = strlen(b)+2;
    i = strlen(a)-1;
    j = strlen(b)-1;
    k = 0;
    up = 0;
    while(j>=0 || i>=0)
    {
        if(i<0) x = '0';
        else
            x = a[i];
        if(j<0) y = '0';
        else
            y = b[j];
        z = x-'0'+y-'0';
        if(up)
            z++;
        if(z>9)
        {
            up = 1;
            z%=10;
        }
        else
            up = 0;
        c[k++] = z+'0';
        i--;
        j--;
    }
    if(up)
        c[k++] = '1';
    i = 0;
    c[k] = '\0';
    for(k-=1; k>=0; k--)
        back[i++] = c[k];
    back[i] = '\0';
}

int main()
{
    int t,len,i,sum,r;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str);
        int flag = 1;
        while(1)
        {
            len = strlen(str);
            sum = 0;
            for(i = 0; i<len; i++)
            {
                sum+=str[i]-'0';
            }
            if(sum%10 || flag)
                add(str,"1",str);
            else
                break;
            flag = 0;
        }
        printf("%s\n",str);
    }

    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值