HDU3567:Eight II(康拓展开+预处理)

Problem Description
Eight-puzzle, which is also called "Nine grids", comes from an old game. 

In this game, you are given a 3 by 3 board and 8 tiles. The tiles are numbered from 1 to 8 and each covers a grid. As you see, there is a blank grid which can be represented as an 'X'. Tiles in grids having a common edge with the blank grid can be moved into that blank grid. This operation leads to an exchange of 'X' with one tile.

We use the symbol 'r' to represent exchanging 'X' with the tile on its right side, and 'l' for the left side, 'u' for the one above it, 'd' for the one below it.



A state of the board can be represented by a string S using the rule showed below.



The problem is to operate an operation list of 'r', 'u', 'l', 'd' to turn the state of the board from state A to state B. You are required to find the result which meets the following constrains:
1. It is of minimum length among all possible solutions.
2. It is the lexicographically smallest one of all solutions of minimum length.
 

Input
The first line is T (T <= 200), which means the number of test cases of this problem.

The input of each test case consists of two lines with state A occupying the first line and state B on the second line.
It is guaranteed that there is an available solution from state A to B.
 

Output
For each test case two lines are expected.

The first line is in the format of "Case x: d", in which x is the case number counted from one, d is the minimum length of operation list you need to turn A to B.
S is the operation list meeting the constraints and it should be showed on the second line.
 

Sample Input
  
  
2 12X453786 12345678X 564178X23 7568X4123
 

Sample Output
  
  
Case 1: 2 dd Case 2: 8 urrulldr
 


题意:由字符串1变成字符串2所需要在最小步数的情况下输出其字典序最小的方案
思路:八数码问题,处理这种问题首先想到的方法自然是康拓,我们可以先枚举X不同位置的9中方案,用bfs搜出这种方案到其他所有方案的移动方法,那么在后面我们就可以直接得出答案,使用逆推的方法

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <stack>
#include <string>
using namespace std;

struct node
{
    int x,y;
    char map[5][5];
    node() {}
    node(char *s)
    {
        int i,j;
        int xx = 0,yy = 0;
        for(i = 0; i<strlen(s); i++)
        {
            map[xx][yy] = s[i];
            if(s[i] == 'X')
            {
                x = xx;
                y = yy;
            }
            yy++;
            if(yy == 3)
            {
                xx++;
                yy = 0;
            }
        }
    }
};

node s;
char str[20];
int num[20],hash[10];
bool vis[500000];
int pre[10][500000],ans[10][500000];
int to[4][2] = {1,0,0,-1,0,1,-1,0};
char way[10] = "dlru";

int solve(node a)//康拓
{
    int i,j,k,cnt,ans = 0;
    int b[20];
    for(i = 0; i<3; i++)
    {
        for(j = 0; j<3; j++)
        {
            b[3*i+j] = a.map[i][j];
            cnt = 0;
            for(k = 3*i+j-1; k>=0; k--)
            {
                if(b[k]>b[3*i+j])
                    cnt++;
            }
            ans+=hash[3*i+j]*cnt;
        }
    }
    return ans;
}

void bfs(int p)
{
    memset(pre[p],-1,sizeof(pre[p]));
    memset(vis,false,sizeof(vis));
    node a,next;
    queue<node> Q;
    Q.push(s);
    vis[solve(s)] = true;
    while(!Q.empty())
    {
        a = Q.front();
        Q.pop();
        int sa = solve(a);
        for(int i = 0; i<4; i++)
        {
            next = a;
            next.x+=to[i][0];
            next.y+=to[i][1];
            if(next.x<0 || next.x>2 || next.y<0 || next.y>2)
                continue;
            next.map[a.x][a.y] = next.map[next.x][next.y];
            next.map[next.x][next.y] = 'X';
            int sb = solve(next);
            if(vis[sb])
                continue;
            vis[sb] = true;
            pre[p][sb] = sa;
            ans[p][sb] = way[i];
            Q.push(next);
        }
    }
}

int main()
{
    int t,i,j,k,cas = 1;
    hash[0] = 1;
    for(i = 1; i<10; i++)
        hash[i] = hash[i-1]*i;

    s = node("X12345678");
    bfs(0);
    s = node("1X2345678");
    bfs(1);
    s = node("12X345678");
    bfs(2);
    s = node("123X45678");
    bfs(3);
    s = node("1234X5678");
    bfs(4);
    s = node("12345X678");
    bfs(5);
    s = node("123456X78");
    bfs(6);
    s = node("1234567X8");
    bfs(7);
    s = node("12345678X");
    bfs(8);

    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str);
        int p;
        for(i = 0,j = 0; i<9; i++)//保存位置,因为前面预处理的都是位置
        {
            if(str[i]=='X') p = i;
            else
                num[str[i]-'0'] = j++;
        }
        scanf("%s",str);
        for(i = 0; i<9; i++)//求出目标状态每个数在原状态的位置
        {
            if(str[i]=='X')
                continue;
            str[i] = num[str[i]-'0']+'1';
        }
        s = node(str);//由目标态逆推到初始态
        int sum = solve(s);
        string ss="";
        while(sum!=-1)
        {
            ss+=ans[p][sum];
            sum = pre[p][sum];
        }
        printf("Case %d: %d\n",cas++,ss.size()-1);
        for(i = ss.size()-2; i>=0; i--)//由于方案是逆推,输出也要逆推
            printf("%c",ss[i]);
        printf("\n");
    }

    return 0;
}


  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值