HDU4864:Task(贪心)

Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1
 

Sample Output
  
  
1 50004
 


题意:n台机器,m个任务,每台机器和任务都有两个值,机器的两个值都大于任务的两个值,这台机器才能完成这个任务,每台机器只能完成一个任务,问最大收益
思路:贪心,标记好暴力即可

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

struct node
{
    int x,y;
} s1[100005],s2[100005];

int cmp(node a,node b)
{
    if(a.x == b.x)
        return a.y>b.y;
    return a.x>b.x;
}

int main()
{
    int n,m,i,j,cnt;
    __int64 sum;
    while(~scanf("%d%d",&n,&m))
    {
        for(i = 0; i<n; i++)
            scanf("%d%d",&s1[i].x,&s1[i].y);
        for(i = 0; i<m; i++)
            scanf("%d%d",&s2[i].x,&s2[i].y);
        sort(s1,s1+n,cmp);
        sort(s2,s2+m,cmp);
        cnt = sum = 0;
        int c[105] = {0};
        for(i = 0,j = 0; i<m; i++)
        {
            while(j<n && s1[j].x>=s2[i].x)
            {
                c[s1[j].y]++;
                j++;
            }
            for(int k = s2[i].y; k<=100; k++)
            {
                if(c[k])
                {
                    c[k]--;
                    sum+=(s2[i].x*500+s2[i].y*2);
                    cnt++;
                    break;
                }
            }
        }
        printf("%d %I64d\n",cnt,sum);
    }
}


  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 5
    评论
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值