POJ1178:Camelot(FLOYD+DP)

Description

Centuries ago, King Arthur and the Knights of the Round Table used to meet every year on New Year's Day to celebrate their fellowship. In remembrance of these events, we consider a board game for one player, on which one king and several knight pieces are placed at random on distinct squares. 
The Board is an 8x8 array of squares. The King can move to any adjacent square, as shown in Figure 2, as long as it does not fall off the board. A Knight can jump as shown in Figure 3, as long as it does not fall off the board. 

During the play, the player can place more than one piece in the same square. The board squares are assumed big enough so that a piece is never an obstacle for other piece to move freely. 
The player's goal is to move the pieces so as to gather them all in the same square, in the smallest possible number of moves. To achieve this, he must move the pieces as prescribed above. Additionally, whenever the king and one or more knights are placed in the same square, the player may choose to move the king and one of the knights together henceforth, as a single knight, up to the final gathering point. Moving the knight together with the king counts as a single move. 

Write a program to compute the minimum number of moves the player must perform to produce the gathering. 

Input

Your program is to read from standard input. The input contains the initial board configuration, encoded as a character string. The string contains a sequence of up to 64 distinct board positions, being the first one the position of the king and the remaining ones those of the knights. Each position is a letter-digit pair. The letter indicates the horizontal board coordinate, the digit indicates the vertical board coordinate. 

0 <= number of knights <= 63

Output

Your program is to write to standard output. The output must contain a single line with an integer indicating the minimum number of moves the player must perform to produce the gathering.

Sample Input

D4A3A8H1H8

Sample Output

10
 
题意,有一个国王和n个骑士在一个8*8的棋盘里,国王可以往邻近的8个点走,骑士走日字姓,问最后都走到同一个格子需要几步,要注意国王一旦与一个骑士相遇之后,他们就是一个整体,按骑士的方法来移动
思路:先用floyd求出所有骑士和国王从各个点到其他点的最短路,然后枚举集合点,枚举哪位骑士和国王相遇
 
<pre name="code" class="cpp">#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
#define ls 2*i
#define rs 2*i+1
#define up(i,x,y) for(i=x;i<=y;i++)
#define down(i,x,y) for(i=x;i>=y;i--)
#define mem(a,x) memset(a,x,sizeof(a))
#define w(a) while(a)
#define LL long long
const double pi = acos(-1.0);
#define Len 63
#define mod 19999997
const int INF = 0x3f3f3f3f;

const int to1[8][2] = {1,0,0,1,-1,0,0,-1,1,1,1,-1,-1,1,-1,-1};
const int to2[8][2] = {1,2,2,1,1,-2,2,-1,-1,2,-2,1,-1,-2,-2,-1};
int king[65][65],knight[65][65];

int main()
{
    int i,j,k;
     mem(king,INF);
     mem(knight,INF);
    up(i,0,Len)
    king[i][i] = knight[i][i] = 0;
    int x1,x2,y1,y2;
    up(i,0,7)
    {
        up(j,0,7)
        {
            up(k,0,7)
            {
                x1 = i+to1[k][0];
                y1 = j+to1[k][1];
                x2 = i+to2[k][0];
                y2 = j+to2[k][1];
                if(x1>=0 && x1<8 && y1>=0 && y1<8)
                    king[i*8+j][x1*8+y1] = 1;
                if(x2>=0 && x2<8 && y2>=0 && y2<8)
                    knight[i*8+j][x2*8+y2] = 1;
            }
        }
    }
    up(k,0,Len)
    {
        up(i,0,Len)
        {
            up(j,0,Len)
            {
                king[i][j] = min(king[i][j],king[i][k]+king[k][j]);
                knight[i][j] = min(knight[i][j],knight[i][k]+knight[k][j]);
            }
        }
    }
    char str[1000];
    int len;
    int arthur,saber[100],l,ans,tem,sum;
    w(~scanf("%s",str))
    {
        len = strlen(str);
        l = 0;
        ans = INF;
        arthur = (str[0]-'A')*8+(str[1]-'1');
        for(i = 2; i<len; i+=2)
            saber[l++] = (str[i]-'A')*8+(str[i+1]-'1');
        up(i,0,Len)
        {
            up(j,0,Len)
            {
                sum = king[arthur][j];//假设国王在j位置遇上了一个骑士
                up(k,0,l-1)
                sum+=knight[saber[k]][i];//假设所有骑士在i点集合,把所有骑士到这个点的步数加起来
                tem = INF;
                up(k,0,l-1)//枚举是第k个骑士与国王相遇,那么这个其实先要移动到j点,然后带着傻逼国王回到i点
                tem=min(tem,sum-knight[saber[k]][i]+knight[saber[k]][j]+knight[j][i]);
                ans = min(ans,tem);
            }
        }
        printf("%d\n",ans);
    }

    return 0;
}



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值