HDU2673:shǎ崽 OrOrOrOrz

Problem Description
Acmer in HDU-ACM team are ambitious, especially shǎ崽, he can spend time in Internet bar doing problems overnight. So many girls want to meet and Orz him. But Orz him is not that easy.You must solve this problem first.
The problem is :
Give you a sequence of distinct integers, choose numbers as following : first choose the biggest, then smallest, then second biggest, second smallest etc. Until all the numbers was chosen .  
For example, give you 1 2 3 4 5, you should output 5 1 4 2 3
 

Input
There are multiple test cases, each case begins with one integer N(1 <= N <= 10000), following N distinct integers.
 

Output
Output a sequence of distinct integers described above.
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
5 1 4 2 3
 


快排的运用

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int cmp(const void *a,const void *b)
{
    return (*(int *)a-*(int*)b);
}

int main()
{
    int n,i,num[10005],a[10005];
    while(cin >> n)
    {
        int flag,flag2;
        flag = n/2;
        flag2 = n-flag;
        memset(a,0,sizeof(a));
        memset(num,0,sizeof(num));
        for(i = 0;i<n;i++)
        cin >> num[i];
        qsort(num,n,sizeof(int),cmp);
        int k = 0;
        for(i = n-1;flag2--;i--)
        {
            a[k] = num[i];
            k+=2;
        }
        k = 1;
        for(i = 0;flag--;i++)
        {
            a[k] = num[i];
            k+=2;
        }
        cout << a[0];
        for(i = 1;i<n;i++)
        {
            cout << " " << a[i];
        }
        cout << endl;
    }

    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值