HDU4156:Egypt

Problem Description
A long time ago, the Egyptians figured out that a triangle with sides of length 3, 4, and 5 had a right angle as its largest angle. You must determine if other triangles have a similar property.

 

Input
Input represents several test cases, followed by a line containing 0 0 0. Each test case has three positive integers, less than 30,000, denoting the lengths of the sides of a triangle.
 

Output
For each test case, a line containing "right" if the triangle is a right triangle, and a line containing "wrong" if the triangle is not a right triangle.
 

Sample Input
  
  
6 8 10 25 52 60 5 12 13 0 0 0
 

Sample Output
  
  
right wrong right
 
一道验证是否直角三角形的题目= =
 
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int a[3];
    while(cin >> a[0] >> a[1] >> a[2])
    {
        if(a[0] == 0 && a[1] == 0 && a[2] == 0)
        break;
        sort(a,a+3);
        if(a[0]*a[0] + a[1]*a[1] == a[2]*a[2])
        cout << "right" << endl;
        else
        cout << "wrong" << endl;
    }

    return 0;
}

 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值