HDU1239:Calling Extraterrestrial Intelligence Again

Problem Description
A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974. The message consisted of 1679 bits and was meant to be translated to a rectangular picture with 23 * 73 pixels. Since both 23 and 73 are prime numbers, 23 * 73 is the unique possible size of the translated rectangular picture each edge of which is longer than 1 pixel. Of course, there was no guarantee that the receivers would try to translate the message to a rectangular picture. Even if they would, they might put the pixels into the rectangle incorrectly. The senders of the Arecibo message were optimistic.  
We are planning a similar project. Your task in the project is to find the most suitable width and height of the translated rectangular picture. The term "most suitable" is defined as follows. An integer m greater than 4 is given. A positive fraction a / b less than or equal to 1 is also given. The area of the picture should not be greater than m. Both of the width and the height of the translated picture should be prime numbers. The ratio of the width to the height should not be less than a / b nor greater than 1. You should maximize the area of the picture under these constraints.

In other words, you will receive an integer m and a fraction a / b. It holds that m > 4 and 0 < a / b < 1. You should find the pair of prime numbers p, q such that pq <= m and a / b <= p / q <= 1, and furthermore, the product pq takes the maximum value among such pairs of two prime numbers. You should report p and q as the "most suitable" width and height of the translated picture.
 

Input
The input is a sequence of at most 2000 triplets of positive integers, delimited by a space character in between. Each line contains a single triplet. The sequence is followed by a triplet of zeros, 0 0 0, which indicated the end of the input and should not be treated as data to be processed.

The integers of each input triplet are the integer m, the numerator a, and the denominator b described above, in this order. You may assume 4 < m <= 100000 and 1 <= a <= b <= 1000.
 

Output
The output is a sequence of pairs of positive integers. The i-th output pair corresponds to the i-th input triplet. The integers of each output pair are the width p and the height q described above, in this order.

Each output line contains a single pair. A space character is put between the integers as a delimiter. No other characters should appear in the output.
 

Sample Input
  
  
5 1 2 99999 999 999 1680 5 16 1970 1 1 2002 4 11 0 0 0
 

Sample Output
  
  
2 2 313 313 23 73 43 43 37 53
 

/*题意: 两个素数 p, q 并且 pq <= m and a / b <= p / q <= 1,
4 < m <= 100000 and 1 <= a <= b <= 1000.求最大的q,p值
*/

#include <stdio.h>
#include <string.h>
const int N = 10005;
int prime[N],p,q,l = 0,s[N];

void set()
{
    int i,j;
    memset(prime,0,sizeof(prime));
    for(i = 2; i<N; i++)
    {
        if(prime[i])
            continue;
        for(j = i+i; j<N; j+=i)
            prime[j] = 1;
        s[l++] = i;
    }
}


int main()
{
    int m,tp,tq,t;
    double a,b,max,lim;
    set();
    while(~scanf("%d%lf%lf",&m,&a,&b),m!=0||a!=0||b!=0)
    {
        max = 0;
        lim = a/b;
        for(p = l-1; p>=0; p--)
        {
            for(q = p; q>=0; q--)
            {
                if(s[p]>m || s[q]>m || s[q]*s[p]>m || (double)s[q]/s[p]<lim)
                    continue;
                if(s[p]*s[q]>max)
                {
                    max = s[p]*s[q];
                    tp = s[p];
                    tq = s[q];
                }
            }
        }
        if(tp>tq)
        {
            t = tp;
            tp = tq;
            tq = t;
        }
        printf("%d %d\n",tp,tq);
    }

    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值