HDU2425:Hiking Trip(BFS+优先队列)

Problem Description
Hiking in the mountains is seldom an easy task for most people, as it is extremely easy to get lost during the trip. Recently Green has decided to go on a hiking trip. Unfortunately, half way through the trip, he gets extremely tired and so needs to find the path that will bring him to the destination with the least amount of time. Can you help him?
You've obtained the area Green's in as an R * C map. Each grid in the map can be one of the four types: tree, sand, path, and stone. All grids not containing stone are passable, and each time, when Green enters a grid of type X (where X can be tree, sand or path), he will spend time T(X). Furthermore, each time Green can only move up, down, left, or right, provided that the adjacent grid in that direction exists.
Given Green's current position and his destination, please determine the best path for him.  
 

Input
There are multiple test cases in the input file. Each test case starts with two integers R, C (2 <= R <= 20, 2 <= C <= 20), the number of rows / columns describing the area. The next line contains three integers, V P, V S, V T  (1 <= V P  <= 100, 1 <= V S  <= 100, 1 <= V T  <= 100), denoting the amount of time it requires to walk through the three types of area (path, sand, or tree). The following R lines describe the area. Each of the R lines contains exactly C characters, each character being one of the following: ‘T’, ‘.’, ‘#’, ‘@’, corresponding to grids of type tree, sand, path and stone. The final line contains four integers, S R, S C, T R, T C, (0 <= S R  < R, 0 <= S C  < C, 0 <= T R  < R, 0 <= T C  < C), representing your current position and your destination. It is guaranteed that Green's current position is reachable – that is to say, it won't be a '@' square.
There is a blank line after each test case. Input ends with End-of-File.
 

Output
For each test case, output one integer on one separate line, representing the minimum amount of time needed to complete the trip. If there is no way for Green to reach the destination, output -1 instead.
 

Sample Input
  
  
4 6 1 2 10 T...TT TTT### TT.@#T ..###@ 0 1 3 0 4 6 1 2 2 T...TT TTT### TT.@#T ..###@ 0 1 3 0 2 2 5 1 3 T@ @. 0 0 1 1
 

Sample Output
  
  
Case 1: 14 Case 2: 8 Case 3: -1
 


 

题意就是给出一个地图,地图有四种路面,经过每种路面花费的时间不同,问从起点到终点所花费的最少时间是多少

本身不难,由于犯了2一直过不了样例,找了老半天终于修正了= =

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;

int n,m;
int map[25][25];//1-T,2-.,3-#,-1-@
int vis[25][25];
int v[5];
int x1,x2,y1,y2,ans;
int to[4][2] = {1,0,-1,0,0,1,0,-1};

struct node
{
    int x,y,step;
     friend bool operator<(node n1,node n2)
    {
        return n2.step<n1.step;
    }

};

int check(int x,int y)
{
    if(x<0 || y<0 || x>=n || y>=m || map[x][y]<0|| vis[x][y])
        return 1;
    return 0;
}

int bfs()
{
    int i;
    priority_queue<node> Q;
    node a,next;
    memset(vis,0,sizeof(vis));
    a.x = x1;
    a.y = y1;
    a.step = 0;
    vis[a.x][a.y] = 1;
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.top();
        Q.pop();
        if(a.x == x2 && a.y == y2)
        return a.step;
        for(i = 0; i<4; i++)
        {
            next = a;
            next.x +=to[i][0];
            next.y +=to[i][1];
            if(check(next.x,next.y))
                continue;
            next.step+=v[map[next.x][next.y]];
            vis[next.x][next.y] = 1;
            Q.push(next);
        }
    }
    return -1;
}

int main()
{
    int i,j,cas = 1;
    char s[100];
    while(~scanf("%d%d",&n,&m))
    {
        scanf("%d%d%d",&v[3],&v[2],&v[1]);
        for(i = 0; i<n; i++)
        {
            scanf("%s",s);
            for(j = 0; s[j]; j++)
            {
                if(s[j]=='T') map[i][j] = 1;
                else if(s[j] == '.') map[i][j] = 2;
                else if(s[j] == '#') map[i][j] = 3;
                else if(s[j] == '@') map[i][j] = -1;
            }
        }
        scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
        ans = bfs();
        printf("Case %d: %d\n",cas++,ans);
    }

    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值