1007. To and Fro

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

代码实现:


#include<stdio.h>
#include<string.h>

int main() {
  int i, j, n, k = 1;
  char s[1000];
  char a[200][200] = {0};
  while (1) {
    scanf("%d", &n);
    if (n == 0 ) break;
    scanf("%s", s);
    k = 1;
    for (i = 0; i < strlen(s)/n; i++) {
      if (k == 1) {
      for (j = 0; j < n; j++) {
      a[i][j] = s[i*n + j];
      }
      k = k*(-1);
      } else {
      for (j = n - 1; j >= 0 ; j--) {
      a[i][j] = s[i*n + n - j - 1];
      }
      k = k*(-1);
      }
    }
    for (j = 0; j < n; j++) {
      for (i = 0; i < strlen(s)/n; i++)
      printf("%c", a[i][j]);
    }
    printf("\n");
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值