1510. Mispelling

题意:

将字符串在指定位置的字符去掉后输出即可

Input

The first line of input contains a single integer N , (1≤N≤1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing M , a space, and a single word made up of uppercase letters only. M will be less than or equal to the length of the word. The length of the word is guaranteed to be less than or equal to 80.

Output

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the misspelled word. The misspelled word is the input word with the indicated character deleted.

Sample Input

4
4 MISSPELL
1 PROGRAMMING
7 CONTEST
3 BALLOON
Sample Output

1 MISPELL
2 ROGRAMMING
3 CONTES
4 BALOON

#include<iostream>
#include<string>
using namespace std;

int main() {
  string str[100];
  int n;
  cin >> n;
  int deletePosition;
  for (int i = 0; i < n; ++i) {
    cin >> deletePosition;
    cin >> str[i];
    str[i].erase(deletePosition - 1, 1);
  }
  for (int i = 0; i < n; ++i)
    cout << i + 1 << " " << str[i] << endl;
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值