PAT A1065 2019.07.04 【模拟】

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

思路分析

特别要注意long long double溢出情况的判断

#include<cstdio>
#include<iostream>

int main()
{
	long long int a;
	long long int b;
	long long int c;
	long long int temp;
	int T;
	scanf("%d", &T);
	for (int i = 1; i <= T; i++)
	{
		scanf("%lld%lld%lld", &a, &b, &c);
		temp = a + b;
		if (a > 0 && b > 0 && temp < 0)printf("Case #%d: true\n", i);
		else if (a < 0 && b < 0 && temp >= 0)printf("Case #%d: false\n", i);
		else if (temp > c)printf("Case #%d: true\n", i);
		else printf("Case #%d: false\n", i);
	}



}

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值