PAT A1002 2019.07.05 【多项式】

该博客详细介绍了PAT A1002编程题的解决方案,涉及两个多项式的相加。输入和输出规格被详细阐述,并提供了一个样例输入和输出。博主分享了思路,提出利用数组存储多项式,并在读取输入时直接累加系数,由于数据规模较小,可直接遍历所有项进行输出,确保结果精确到小数点后1位。
摘要由CSDN通过智能技术生成

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

思路分析

利用数组存储多项式

在输入的同时可以对最后输出的多项式系数进行累加

因为数据量比较小,所以可以直接遍历MAX来进行输出 

#include<cstdio>
#include<iostream>
#define MAX 2500
int up1[MAX]={0};
double down1[MAX]={0};
int up2[MAX]={0};
double down2[MAX]={0};

double sum[MAX]={0}; 

int main()
{
	//输入模块 
	int k1=0,k2=0;
	scanf("%d",&k1);
	for(int i=0;i<k1;i++)
	{
		scanf("%d %lf",&up1[i],&down1[i]);
		sum[up1[i]]=sum[up1[i]]+down1[i];
	}
	scanf("%d",&k2);
	for(int i=0;i<k2;i++)
	{
		scanf("%d %lf",&up2[i],&down2[i]);
		sum[up2[i]]=sum[up2[i]]+down2[i];
	}
	
	//输出部分1 
	int number=0;
	for(int i=0;i<MAX;i++)
	{
		if(sum[i]!=0)number++;
	}
	printf("%d",number);
	
	//输出部分2 
	for(int i=MAX-1;i>=0;i--)
	{
		if(sum[i]!=0)
		{
			printf(" %d %0.1lf",i,sum[i]);
		}
	}
	
	
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值