PAT A1134 2018.08.18 【图】

1134 Vertex Cover (25 分)

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

思路分析

用一维固定二维变长的数组建立邻接链表用来存储图

给定若干结点,判断这些结点与其所连接的边的集合是不是全体边的集合。

邻接链表恰好可以对应从顶点x到顶点y的边,只需对测试点的邻接链表项的访问标志位置位即可(两个结点邻接链表双向置位)

之后再对整个邻接链表进行遍历寻找-没有置位的标志位-即可

此题如果使用二维固定数组作为标志位数组会出现段错误,并超时

我做时采用了一维固定数组作为标志位数组( visit[i*10+j] rather than visit[i][j] )

#include<cstdio>
#include<iostream>
#include<vector>
#define MAX 1001000
using namespace std;

vector<int> adl[MAX];
int visit[MAX];


int main()
{
	int n,m;
	scanf("%d %d",&n,&m);
	for(int i=0;i<m;i++)
	{
		int a,b;
		scanf("%d %d",&a,&b);
		adl[a].push_back(b);
		adl[b].push_back(a);
	}
	
//	for(int i=0;i<n;i++)
//	{
//		if(adl[i].size()==0)
//		{
//			printf("vertex #%d:\n",i);
//			continue;
//		}
//		
//		printf("vertex #%d:",i);
//		for(int j=0;j<adl[i].size();j++)
//		{
//			printf(" %d",adl[i][j]);
//		}
//		printf("\n");
//	}
    
    int k;
    scanf("%d",&k);
    while(k--)
    {
    	int flag=1;
    	for(int i=0;i<MAX;i++)
		  visit[i]=0;
		  
    	int vn;//vector num
    	scanf("%d",&vn);
    	while(vn--)
    	{
    		int v;
    		scanf("%d",&v);
    		for(int i=0;i<adl[v].size();i++)
			{
				visit[v*10 + adl[v][i]]=1;
				visit[10*adl[v][i] + v]=1;
//				printf(" %d-%d ",v*10 + adl[v][i],10*adl[v][i] + v);
			}
    		
		}
		
		for(int i=0;i<n;i++)
		{
			if(adl[i].size()==0)
			{
				continue;
			}
			
			for(int j=0;j<adl[i].size();j++)
			{
				if(visit[i*10+adl[i][j]]==0)
				{
					flag=0;
//					printf("%d ",i*10+adl[i][j]);
				}

			}

		}
		
		if(flag==0)printf("No\n");
		else printf("Yes\n");
    	
    	
    	
	}
	
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值