PAT-A1134 Vertex Cover 题目内容及题解

A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​^4​​), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ v[1] v[2]⋯v[N​v​​]

where N​v​​ is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

题目大意

图的顶点覆盖是指图的一个顶点集合使图的所有边都有至少一个端点在顶点集合中。题目给定一副图和一组顶点集合,判断给定的顶点集合是否为顶点覆盖。

解题思路

  1. 初始化、读入图中的边并存储;
  2. 对每个输入样例循环检查:先初始化,再将出现的端点进行打表,之后对每条边进行检查,并输出结果;
  3. 当检查并输出完成后返回零值。

代码

#include<stdio.h>
#define maxn 10010

int N,M,K;
int E[maxn];
struct Node{
    int a,b;
}node[maxn];
void Init(){
    int i;
    scanf("%d%d",&N,&M);
    for(i=0;i<M;i++){
        scanf("%d%d",&node[i].a,&node[i].b);
    }
    scanf("%d",&K);
}
void Check(){
    int i,nv,a;
    for(i=0;i<N;i++){
        E[i]=0;
    }
    scanf("%d",&nv);
    while(nv--){
        scanf("%d",&a);
        E[a]=1;
    }
    for(i=0;i<M;i++){
        if(E[node[i].a]==0&&E[node[i].b]==0){
            printf("No\n");
            return;
        }
    }
    printf("Yes\n");
}

int main(){
    Init();
    while(K--){
        Check();
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值