Drying POJ - 3104 求最小值,二分。

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

题意:n件衣服。 每件有ai的水分,不用吹干机的衣服每分钟减少1水分,用吹干机的衣服在那一分钟减少k的水分。 问最少需要对少时间才能风干所有衣服。
问题明显具有单调性,所以只需要二分查找即可。

/*解法 最大最小值,赤裸裸的二分套路题。。。  然而还是想了好久 太菜了太菜了。
        这题的check函数直接暴力遍历的话会超时,因此要优化一下。 假设check(mid)  
        不用吹干机的话,每件衣服能少mid水分,如果这件衣服还有剩余水分,那肯定要用吹干机
        把所有衣服要用吹干机的次数(sum)加起来,return mid>= sum; 即可*/
#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
using namespace std;
long long  sum,k;
long long a[100010];
bool check(long long time)
{
    long long thesum=0;
    for(int i=0;i<sum;i++)
    {
        if(a[i]>time)
            thesum+=(a[i]- time+k-2)/(k-1);
    }
    return thesum>time;
}
int main()
{
    while(~scanf("%lld",&sum))
    {
        long long l=1,r=-1;
        for(int i=0;i<sum;++i)
        {
            scanf("%lld",&a[i]);
            if(r<a[i])
                r=a[i];
        }
        scanf("%lld",&k);
        long long mid;
        if(k==1)
            printf("%lld\n",r);
        else
        {
        while(l<r-1)
        {
            mid=(l+r)>>1;
            if(check(mid))
                l=mid;
            else
                r=mid;
        }
        printf("%lld\n",r);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值