HDU 6143 Killer Names(排列+容斥,dp)

Killer Names

HDU 6143 (容斥+排列组合,dp+整数快速幂) 2017ACM暑期多校联合训练 - Team 8 1011 Killer Names

题目链接

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1107 Accepted Submission(s): 545

Problem Description

Galen Marek, codenamed Starkiller, was a male Human apprentice of the Sith Lord Darth Vader. A powerful Force-user who lived during the era of the Galactic Empire, Marek originated from the Wookiee home planet of Kashyyyk as the sole offspring of two Jedi Knights—Mallie and Kento Marek—who deserted the Jedi Order during the Clone Wars. Following the death of his mother, the young Marek’s father was killed in battle by Darth Vader. Though only a child, Marek possessed an exceptionally strong connection to the Force that the Dark Lord of the Sith sought to exploit.

When Marek died in 2 BBY, shortly after the formation of the Alliance, Vader endeavored to recreate his disciple by utilizing the cloning technologies of the planet Kamino. The accelerated cloning process—an enhanced version of the Kaminoan method which allowed for a rapid growth rate within its subjects—was initially imperfect and many clones were too unstable to take Marek’s place as the Dark Lord’s new apprentice. After months of failure, one particular clone impressed Vader enough for him to hope that this version might become the first success. But as with the others, he inherited Marek’s power and skills at the cost of receiving his emotions as well, a side effect of memory flashes used in the training process.

— Wookieepedia

Darth Vader is finally able to stably clone the most powerful soilder in the galaxy: the Starkiller. It is the time of the final strike to destroy the Jedi remnants hidden in every corner of the galaxy.

However, as the clone army is growing, giving them names becomes a trouble. A clone of Starkiller will be given a two-word name, a first name and a last name. Both the first name and the last name have exactly n characters, while each character is chosen from an alphabet of size m. It appears that there are m2n possible names to be used.

Though the clone process succeeded, the moods of Starkiller clones seem not quite stable. Once an unsatisfactory name is given, a clone will become unstable and will try to fight against his own master. A name is safe if and only if no character appears in both the first name and the last name.

Since no two clones can share a name, Darth Vader would like to know the maximum number of clones he is able to create.

Input
The First line of the input contains an integer T (T≤10), denoting the number of test cases.

Each test case contains two integers n and m (1≤n,m≤2000).

Output
For each test case, output one line containing the maximum number of clones Vader can create.

Output the answer mod 109+7

Sample Input
2
3 2
2 3

Sample Output
2
18

题意:
有m种字符(可以不用完),组成两个长度为n的字符串,要求这两个字符串中不含有相同的字符。

求有多少种方式组成这两个字符串。

dp求解
嘿嘿 在学姐博客复制过来的 学姐 博客
还是dp代码短呀,就是不好想。

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod = 1e9 + 7;
const int maxn = 2010;
ll dp[maxn][maxn];

ll quick_pow(ll a, ll b)///整数快速幂
{
    ll ans = 1;
    while (b)
    {
        if (b & 1)    
            ans = ans*a%mod;
        a = a*a%mod;
        b >>= 1;
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        dp[1][1]=m;///第一个位置放置一种字符的方案数有且仅有一个
        for(int i=2; i<=n; i++)///从第二个位置遍历到第n个位置
        {
            for(int j=1; j<=i&&j<=m; j++)///前i个位置可以选择放的不同字符的个数最少为1个,最多为i个(每个位置上的字符都不一样)
            {
                /*
                要使前i个位置上有j个不同的字符,考虑两种方案数
                1.前i-1个位置上就已经有了j个不同的字符了,那么第j个位置上就可以从这j个字符中任意选择一个
                2.前i-1个位置上只有j-1个不同的字符,那么第j个位置上的字符就不能选择已经选过的j-1个字符了,
                  需要从剩余的(m-(j-1))个字符里面任意的选择一个
                这两种方案数共同构成
                */
                dp[i][j]=(dp[i-1][j]*j%mod+dp[i-1][j-1]*(m-j+1)%mod)%mod;
            }
        }
        /*
        dp求出来的只是组成姓这n个字符的不同的方案数,我们还要考虑组成名的不同的方案数
        组成名的字符要从剩余的(m-j)个字符里面选择,每个字符都对应着n中摆放位置,两两组合的方案数肯定是乘的关系
        最后将求得的结果累加
        */
        ll ans=0;
        for(int j=1; j<m; j++)
        {
            ans=(ans+dp[n][j]*quick_pow(m-j,n)%mod)%mod;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

分析:
容斥+排列组合

#include <bits/stdc++.h>
#define siz 1005
#define maxn 2000
const long long  mod = 1e9 + 7;
typedef long long LL;
using namespace std;
int n, m;
LL deposit[maxn + 5][maxn + 5], f[maxn + 5], comd[maxn + 5][maxn + 5];
void Init()
{
    for(LL i = 1; i <= maxn; i++)
    {
        deposit[i][0] = 1;
        for(int j = 1; j <= maxn; j++)
            deposit[i][j] = deposit[i][j - 1] * i % mod;///deposit[i]保存i的i的阶乘
    }
    for(int i = 0; i <= maxn; i++)
    {
        comd[i][0] = 1;
        for(int j = 1; j <= i; j++)
            comd[i][j] = (comd[i - 1][j] + comd[i - 1][j - 1]) % mod;///Comd[i]保存i的从i里面取j个的排列组合数的个数
    }
}
void solve()
{
    LL sum = 0;
    memset(f, 0, sizeof(f));
    for(int i = 1; i <= m && i <= n; i++)
    {
        sum = 0;
        for(int j = 1; j <= i; j++)
        {
            sum = (sum + f[j] * comd[i][j] % mod) % mod; 
        }
        f[i] = (deposit[i][n] - sum + mod) % mod;
    }
    LL ans = 0;
    for(int i = 1; i <= n; i++)
    {
        for(int j = 1; j <= n; j++)
        {
            if(i + j > m) break;
            ans = (ans + (((f[i] * f[j]) % mod) * ((comd[m][i] * comd[m - i][j]) % mod)) % mod) % mod;///组合的方法
        }
    }
    printf("%lld\n", ans);
}
int main()
{
    int T;
    Init();
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d %d", &n, &m);
        solve();
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值