SDAU 课程练习 1022

Problem V

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 24   Accepted Submission(s) : 8
Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.<br><br><center><img src=../../../data/images/con211-1010-1.jpg></center> <br>For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.<br><br><br>His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . <br>Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.<br><br>Notes and Constraints<br> 0 < T <= 100<br> 0.0 <= P <= 1.0<br> 0 < N <= 100<br> 0 < Mj <= 100<br> 0.0 <= Pj <= 1.0<br> A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
 
题目大意:

给出最大可忍受概率,给出  n  个银行,给出没家银行可获得的价值,给出偷这家银行的危险概率。求出在不超过危险概率的情况下,可以获得的最大价值。

思路:

如果是直接求的话,还要考虑去重就是高中学过的数学概率嘛。求他的反面就只需要计数相乘了对吧?
每个安全的概率相乘。  因为只要相乘到某一个  得到的概率小于最大安全概率,那么就结束了。
还有就是有个边界的状态,  一家银行也不偷的时候安全概率为  1 。
这里是用没家银行的价值作为物品的体积。为什么要这样做呢?因为数组的下标不能为 负,对吧?扩大一百倍的话也很容易出错的,对吧?
这样倒过来得到最后的结果一样。得到的最大安全概率时候的背包容量就是最大价值。

感想:

这个就只是     0  1  背包的变形。状态的赋值很重要。是的吧?

AC代码:

#include <stdio.h>
#include<iostream>
#include<cstdio>
#include<string.h>
using namespace std;
double val[10005];
int w[10005];
double dp[100005];
int main()
{
    //freopen("r.txt","r",stdin);
    int T,n,i,j;
    double tt;
    cin>>T;
    while(T--)
    {
        int  V;
        V=0;
        double p;
        scanf("%lf%d",&p,&n);
        p=1-p;
        //cout<<p<<endl;
        for(i=0;i<n;i++)
        {
            scanf("%d%lf",&w[i],&val[i]);
            val[i]=1-val[i];
            V+=w[i];
            //cout<<val[i]<<endl;

        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(i=0;i<n;i++)
        {
            for(j=V;j>=w[i];j--)
            {
                if(dp[j]<(dp[j-w[i]]*val[i]))
                    dp[j]=dp[j-w[i]]*val[i];
               // cout<<dp[j]<<endl;
            }
        }
        for(i=V;i>=0;i--)
        {
            if((dp[i]-p)>0.0000001)
            {
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值