HDU 2680:Choose the best route【Dijkstra & SPFA】

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10287    Accepted Submission(s): 3317


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 


从起点往终点找要多次调用函数,很容易超时~所以需要反着来~~只调用一次函数~~而且还要注意的是。。。路径是单向的~~

AC-code:

Dijkstra:

#include<cstdio>
#define max 0x3f3f3f3f
#define min(a,b) (a>b?b:a)
int n,dis[1005],cost[1005][1005];
void dijkstra(int a)
{
	int vis[1005],i;
	for(i=1;i<=n;i++)
	{
		dis[i]=max;
		vis[i]=0;
	}
	dis[a]=0;
	while(1)
	{
		int v=-1;
		for(i=1;i<=n;i++)
			if(!vis[i]&&(dis[i]<dis[v]||v==-1))
				v=i;
		if(v==-1)
			break;
		vis[v]=1;
		for(i=1;i<=n;i++)
			dis[i]=min(dis[i],dis[v]+cost[v][i]);
	}
}
int main()
{
	int so[1005],m,s,i,j,a,b,c;
	while(~scanf("%d%d%d",&n,&m,&s))
	{
		int ans=max;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				cost[i][j]=max;
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);
			cost[b][a]=min(cost[b][a],c);
		}
		scanf("%d",&a);
		dijkstra(s);
		for(i=0;i<a;i++)
		{
			scanf("%d",&b);
			ans=min(ans,dis[b]);
		}
		if(ans==max)
			printf("-1\n");
		else
			printf("%d\n",ans);
	}
	return 0;
}


 SPFA:

#include<cstdio>
#include<queue>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;
int num,dis[1005],vis[1005],head[20005*2];
struct node
{
	int from,to,val,next;
}A[20005*2];

void chan(int a,int b,int c)
{
	node e={a,b,c,head[a]};
	A[num]=e;
	head[a]=num++;
}

void spfa(int sx)
{
	queue<int>q;
	memset(vis,0,sizeof(vis));
	memset(dis,INF,sizeof(dis));
	q.push(sx);
	vis[sx]=1;
	dis[sx]=0;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		for(int i=head[u];i!=-1;i=A[i].next)
		{
			int v=A[i].to;
			if(dis[v]>dis[u]+A[i].val)
			{
				dis[v]=dis[u]+A[i].val;
				if(!vis[v])
				{
					vis[v]=1;
					q.push(v);
				}
			}
		}
	}
}
int main()
{
	int n,m,s,p,q,t,w;
	while(~scanf("%d%d%d",&n,&m,&s))
	{
		num=0;
		memset(head,-1,sizeof(head));
		while(m--)
		{
			scanf("%d%d%d",&p,&q,&t);
			//chan(p,q,t);路径是单向的~~~
			chan(q,p,t);
		}
		spfa(s);
		scanf("%d",&w);
		int min=INF;
		while(w--)
		{
			scanf("%d",&p);
			if(min>dis[p])
				min=dis[p];
		}
		if(min==INF)
			printf("-1\n");
		else
			printf("%d\n",min);
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值